3

I am using the Macbook Pro early 2015, Yosemite 10.10.5.

History

I was trying to fix a wireless keyboard problem with it's escape key, so I downloaded Karabiner for Mac (https://pqrs.org/osx/karabiner/). I couldn't ever get the wireless keyboard to work, so I've returned it and trying to use my internal Mac keyboard again.

Issue

I am noticing that the button "3" is not doing anything. I press it, and nothing registers. So I uninstalled Karabiner through Karabiner's uninstall utility, thinking that it would solve the issue. But the problem persists - the "3" button doesn't do anything. Every other key works great, no problems.

What's even more strange is that I can press "option" + "3", and I get the £ symbol. So clearly the button is not "broken" in terms of hardware, because I can definitely use it after pressing "option". So what is happening when I press "3"?

I reinstalled Karabiner to see if there was a setting I could fix. I used Karabiner's EventViewer, which shows what keyboard code is being used, etc. When I press "3", literally nothing get's logged or trigged. When I press "option" + "3", it shows the logs and triggers.

When I open the Mac Virtual keyboard onscreen, press the button "3" - nothing happens!

I've tried restoring Karabiner to default settings, tried uninstalling it again - no luck.

What is going on? How come "3" does nothing by itself? Super annoying.

UPDATE

Still having the problem, but I've noticed that in safe mode the "3" works fine and normal. How do I debug this knowing that bit of information now?

1

Based on Safe Mode comment, make sure the Karabiner kext (kernel extension) is uninstalled. Look in /System/Library/Extensions.

Check both your home directory Library/Application Support folder and the System/Library/Application Support folders and make sure the Karabiner folder is deleted--which should contain the private.xml document.

Safe Mode does not load non-Apple kexts so that suggests to me that the Karabiner kext did not get uninstalled. Not sure but I think the mods you make end up in that private.xml file. Lots of other files in that folder too. The uninstall scripts look like they should work but it's important to verify this yourself manually. Trust but verify....

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .