8

I don't use iTunes, but I can't prevent it from automatically opening every time a CD is inserted.

I have already changed the system preferences for when a CD/DVD is inserted to "ignore" or to "open other program"-- but it seems that iTunes 12 overrides these system preferences.

I've also looked at the preferences within iTunes, but there is no option to "ignore" when CD is inserted (though I am almost certain there used to be!)

Any suggestions?

My system preferences:

The iTunes preferences options:

  • Anyone found an answer to this in the meantime? I experience the same exact problem – Wirsing Mar 10 '17 at 20:50
  • This is especially a problem when ripping content protected CDs since iTunes will always access the CD first and then proceed to freeze up while hogging drive, making it impossible for other software to handle it. – Magnus Lind Oxlund Feb 11 at 11:28
1

Look at ~/Library/Preferences/com.apple.digihub.plist.

You might also try backing up the file, deleting it, and letting it get re-created.

See also: https://www.jamf.com/jamf-nation/third-party-products/files/408/apple-digihub-settings

0

It's a setting that you need to change in iTunes: Open iTunes Go to the Settings and look for the option ... when cd is inserted... You need to deactivate that, and your problem will be solved. Well I hope this will.

Edit: sorry, i went to fast and I posted info you allready have!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .