4

I recently installed the 10.10.5 update on my Macbook Pro, and now upon login with my home account, the dock won't launch (literally, there is no Dock process; killall Dock returns No matching processes belonging to you were found. Another command I've tried is sudo /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock, and this returns 2015-09-16 10:26:35.219 Dock[1854:178195] __33-[WVSpaces _initializeFullscreen]_block_invoke: fullscreen message error: Connection invalid). In addition, several standard user interface elements, such as command-tab, spaces, and trackpad gestures, no longer work. When I login as a guest user, though, everything works just fine. I'm confused how to get these UI elements working again.

Edit: I've checked the system console, and it appears as if the dock is constantly trying to launch, but failing.

5

Sometimes the LaunchAgent (launchd job) that ensures that the Dock starts up gets stuck. Try unloading and re-loading it:

launchctl unload -F /System/Library/LaunchAgents/com.apple.Dock.plist
launchctl   load -F /System/Library/LaunchAgents/com.apple.Dock.plist
launchctl start com.apple.Dock.agent

The Dock is an app, and apps run as the current user, not as root. (To convince yourself that this is true, remember that each user has their own Dock.) So don't start it with sudo, unless you want to see the root user's Dock. You should be able to start it the way you did (except without sudo), given that the LaunchAgent is unloaded:

launchctl unload -F /System/Library/LaunchAgents/com.apple.Dock.plist
/System/Library/CoreServices/Dock.app/Contents/MacOS/Dock

The reason you need to unload the LaunchAgent is because it will reserve certain ports/services for use by the Dock process it's (unsuccessfully) trying to launch. This keeps your manually-launched Dock process from using them.

  • The first commands don't do anything; the second set of commands returns pretty much the same error as above, except with "Floating point exception: 8" below. – Precipitato Sep 19 '15 at 15:49
  • 2
    Sorry this answer didn't solve your problem. I've never seen "Floating point exception: 8" before. Since you said it works with a guest user, that means the problem is necessarily in your home folder. You could try moving aside user files Dock uses (~/Library/Preferences/com.apple.dock.plist, ~/Library/Application Support/Dock) and try logging out and back in. It's probably too late to help you with this problem but perhaps this tip can help you and other people in similar situations. – interestinglythere Jul 3 '16 at 10:49
  • 1
    To throw my experience in the pool, I just ran into the same problem after choosing an (apparently) malformed image file for my background. The trick ended up being what interestinglythere suggested in the comment: moving aside the Application Support/Dock folder. – Jesse Gallagher Apr 17 '18 at 16:29
  • As @JesseGallagher said, just trash (or move somewhere) ~/Library/Application\ Support/Dock . For me this helped to unlock Dock and other system features that were broken. In my case in my Dock folder I found: desktoppicture.db desktoppicture.db.corrupt – Marcin Magnus Oct 16 '18 at 15:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .