1

I've been handed admin duties for a room full of iMacs running Mavericks (i.e. I don't know all of the configuration tweaks or installed software done by the previous admin). My first goal was to see if they could upgrade to Yosemite, so I tried it on one.

Now, it boots to a white/grey screen with a mouse cursor which follows my mouse movements.

I've tried all of the standard suggestions: reset SMC, reset PRAM, use recovery mode to repair disk and permissions. Nothing fixes this nor changes this white-screen-with-mouse-cursor behavior.

Booting into recovery mode works as on normal machines. Booting in safe-mode gives the white-screen-with-mouse-cursor.

Although the first upgrade I tried was just from within the booted Mavericks OS, I also tried installing/upgrading again from Yosemite on a USB stick and it brought me to this same state of white-screen-with-mouse-cursor.

I then added a 2nd partition on the drive and installed a fresh Yosemite, and that worked. So, a stock Yosemite works. So I don't think there's anything wrong with the hardware.

Because I have a working, parallel MacOS, from which I can fiddle with the volume with the problems, I'm interested in removing/disabling low-level, non-stock additions to the OS: kexts, plists... all the stuff down in /System and /Library which gets loaded at boot time before the login screen is shown. Then, I can disable some add-ons, try booting the original volume, disable some other stuff, try booting again, etc.. But, I don't know a good, systematic way to go about this. Question: Where on the problem volume should I be looking for user-added mods/drivers/kexts/plists and how can I easily spot them among the original Yosemite stuff?

1

Try running EtreCheck. It will provide a lot of useful information on the configuration of your Macs (including a list of the kernel extensions, launch agents, launch daemons, etc).

If you need more guidance you can copy and paste the output from EtreCheck into a Gist, add a link to the Gist to your question above and I'll update my answer.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .