1

I have to develop an app for a specific version of iOS (I am just a freelancer, doing what I am told).

How I install iOS 8.2, or below (8.1, 7.x are fine too) on an iPhone 4S?

1

There's no official way of installing an older iOS on a device that Apple has stopped signing the SHSH keys for.

Your best bet is either to get a hold of a device that still has an older iOS or just using a simulator when developing the app.

  • The app uses camera. The device actually had 7.1 in it, and I updated it by mistake (while trying to control the device without using the touch-screen, taht has the touch part partially non-functioning) – speeder Sep 16 '15 at 8:10
0

Short answer, you don't.

Apple will only sign the current OS, or in the case of a device incapable of running the current OS, the latest it supports.

There are no models that support iOS 8 that don't also support up to 8.4.1 [& even the coming iOS 9]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .