I used to be able to just quicklook files and copy the text directly from there, removing the need to launch applications to open it which is just awesome, however, it doesn't seem to work since El Capitan. I have tried running the terminal command (defaults write com.apple.finder QLEnableTextSelection -bool TRUE) that enables it but it didn't work.

What options exist to customize quick look or replace the default plug in with one that allows text selection?

  • 2021 update, this function was reintroduced in macOS 12 Monterey. Commented Dec 21, 2021 at 8:19

2 Answers 2

  1. It's not that the defaults write command fails. I verified the file, and it wrote the variable to it. The problem is somewhere in the design. Maybe they have moved it? I have been looking in the containers and other files but no luck yet. I hope they didn't completely kill it. Maybe there is a way to copy the old Yosemite version of QL back? If I figure it out, I will update here. https://discussions.apple.com/thread/7250702

  2. TRUE - YES or 1 have the same effect, so, there is no problem on this side.

  3. The option is no longer available on Onyx or TinkerTools too :

enter image description here

Conclusion :

Actually there is no solution to get back the text edit feature on Quick Look.

Following this Apple Thread is the last way to keep hope

It is worth noting that you can copy from spotlight for certain files, as discovered here. Not a great workaround but still allows copying without opening a file. The supported file types are the following:

  • .doc/.docx/.pps/.ppt/.pptx/.xls/.xlsx (also scrollable)
  • .rtf including text-based .rtfd
  • .numbers '09 v2.3, keynote '09 v5.3
  • .odt
  • all text based documents, including source code, xml, plists, and .command files
  • compatible image types
  • 2
    This sucks. It was one of the best features of Mac OS X. Why would they remove it? Commented Oct 27, 2015 at 13:58
  • I think the problem is somewhere in the design (click and move the window is in conflict with the text selection)... Perhaps the feature will be back in the next EC update ^^
    – StrawHara
    Commented Oct 27, 2015 at 14:20
  • I understand that design problem, but it's not on on default, most users won't bother with Terminal commands like that so it shouldn't be a problem. I hope it comes back too, if it doesn't I hope someone makes a plugin. Commented Oct 27, 2015 at 16:16

Just to tie together the comments & partial answers…

Current state of play [as of OS X 10.11.2] would actually appear to be "this can no longer be done".

Regarding the following on QLEnableTextSelection… that one alternative will fix it whilst the other doesn't appears to be some kind of hopeful, yet unfounded, meme going round the interweb - people posting it on as received wisdom, without actually testing it.

Here is the method anyway… though it doesn't work for El Capitan...

Test whether the pref already exists, & if it does what its current value is, using
defaults read com.apple.finder QLEnableTextSelection

Then try one of these to set your new pref
defaults write com.apple.finder QLEnableTextSelection -bool TRUE or
defaults write com.apple.finder QLEnableTextSelection -bool YES

Test again to check the value was at least written, should return 1 if present & enabled.

Restart the Finder if your result did change from 0 to 1.

Empirically, YES & TRUE give the same result, as do NO & FALSE

  • The result of the read command for me is 1, but I still can't select text...
    – user24601
    Commented Oct 19, 2015 at 6:50
  • As I kind of suspected; you can add the default, but it's not being acted on. I'm not on el cap yet [was for one afternoon but rolled back] so I couldn't test. I just thought it better to drag the disparate info into a single answer, though.
    – Tetsujin
    Commented Oct 19, 2015 at 6:53
  • In the past, I've seen a preference type change from an int "1" (or, maybe a string "YES") to bool "TRUE" when the OS version was updated. Hard to imagine that the reverse would happen, but not completely unthinkable. No ElCap installation for me to check yet.
    – Kent
    Commented Oct 26, 2015 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .