Say I have 2 finder windows open, A and B.

I begin focussed on A, then ⌘ + ~ to focus on B, finally ⌘ + ~ once more, and it still leaves B in front, but B is now slightly grayed out (same style as finder window A when it's behind other finder windows).

This 3rd location is focussed on the Desktop, how do I prevent the Desktop from receiving focus on ⌘ + ~? I only want actual Finder windows to receive focus?

It is selecting the Desktop, and any icons on it.

Change Finder App Cycle Window Behaviour

To prevent the Desktop from receiving focus on +~, you will need to change the shortcut for Finder's menu option Cycle Through Windows.

  1. Open System Preferences
  2. Open the Keyboard setting
  3. Select the Shortcuts menu button
  4. Select the App Shorcuts from the list in the left window pane
  5. Click the + button
  6. For Application: option, select Finder
  7. For Menu Title: enter Cycle Through Windows
  8. For Keyboard Shortcut: perform ++ (or any you are comfortable)

Check Keyboard Shortcut for Move Focus to Next Window

  1. Open System Preferences
  2. Open the Keyboard setting
  3. Select the Shortcuts menu button
  4. Select the Keyboard from the list in the left window pane
  5. Check the keyboard shortcut for Move focus to next window
  6. You may need to enable it, and you may need to change it to +`

Note: ++` will then be your +~ and will be for Move focus to *previous* window shortcut.

Operating System

macOS (High Sierra) v10.13.6

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.