1

I have an iPhone 5s (iOS 7.1) and a MBP (Retina, late 2013) (Yosemite). I used to exchange files over Airdrop in both directions. Now sending files only works from the MBP to the iPhone. Sending from the iPhone automatically says declined by the MBP. (I don't even get the download prompt.)

Also, not sure this is relevant, but before the devices used to be able to see each other with the "Contacts only" setting. Now I have to set them both to "Everyone" for them to see each other.

What can be the problem? How can I debug this? I've restarted both devices, stopped Little Snitch, nothing changes.

Update:

Found this message in the Console app:

AirDrop failed to validate Apple ID certificate of sender

So I signed out and back to Apple ID on the phone and reset the network settings, still doesn't work.

1

I have a similar problem.

How does Airdrop work under the hood

Got some helpful answers here, but did not fix my problem. Today I took my iPhone 5s (8.4, but I had the problem under iOS 7) to the Apple store and tested it on a brand new MBP. It worked fine both ways.

Other experiments I ran before: MBP to iPad mini - worked fine both ways. iPad mini to iPhone 5s - worked fine both ways.

So I do not have the full answer, but I now believe that the combination of hardware (both my MBP and iPhone 5s are old, Airdrop was introduced later) is the cause of the problem. I do not think it can be fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .