I've got a Macbook Pro 2008 15" 4,1 with OS X Yosemite 10.10.5 and the latest Firmware and both fans run the whole time at fullspeed. My research brings up, that it's probably the temperature Sensor, because every Software I use to get Information about the temperature it says 0 degrees. For Example iStats says 0 degrees and 0 fans found. The keyboard backlight doesn't work either. (altough it's enabled in preferences). All in all this sounds like a problem where SMC reset would help. Unfortunatelly I have no Battery (it blew up), so I did the reset without the battery part (cant tell if it makes a difference)

Apple Hardware Test couldn't find any problems on my System (both tests). The RAM has been upgraded a while back, but all ribbon cables are correctly connected. picture of bash with istats displaying 0 degrees and 0 fans

Does anybody know how I can solve this problem? The CPU load is constantly pretty low and the MacBook is pretty cold at all.

Log Files a lot of smc errors: http://pastebin.com/egYkGMrz

Interesting part:

Sep 13 21:18:09 Dominiks-MBP kernel[0]: WARNING - ACPI_SMC_CtrlLoop::initCPUCtrlLoop - no sub-config match for MacBookPro4,1 with 8 p-states, using default stepper instead

2 Answers 2


SMC Reset

To your minor question: I do not think the absence of the battery should affect the SMC reset. Source: I have successfully done this with an older mac with no battery and corrected fan problems.

Key Observations

Since it is not obvious what your problem is, I will cover some bases starting with some key observations:

  1. You did not mention resetting the NVRAM/PRAM which I also did when fixing my fan issue. Have you also reset the PRAM/NVRAM? That would one of the two immediate troubleshooting steps I would do with something that looks like a firmware issue. (I believe you hold down the key for 3 chimes btw… not sure if it tells you that on the site.)

  2. Since your diagnostics do not appear to be reading your CPU temperature accurately (it should definitely not be 0C (34 degrees F). I would try again with a different diagnostic, and/or repair permissions using diskutil, run with sudo to ensure the program is able to access the requisite files to generate real output.


Some possibilities and thoughts to facilitate further troubleshooting:

While in diskutil I would check that your drive is in good health. HDD's only operate for 5-10 years. My 08 pro has a dead drive… it may be working hard to keep it at a low temp so it doesn't lock up? Physical wear on the drive can also generate heat.

I would check out your system diagnostics to see if anything is hogging resources. Assuming your hardware isn't screwed up and it's not firmware, I would check to make sure the kernel isn't panicked or some weird unrecognized process isn't interfering with your system.

I note that without an intermediary battery your computer may not be getting a completely regular power source… what comes out of your wall may be lower or higher voltage than expected. Sometimes that generates heat and causes fans to go insane. Sometimes that can "zap" files. You may wish to reinstall your OS without deleting your files and configurations, to make sure everything is in good order.

You may also wish to get your hands on a battery to see if that makes a difference. These cannot be too expensive nowadays… someone may have one laying around. The fact that yours once exploded also… you may be able to get one from Apple even if you're not covered. They really don't get a lot out of keeping and warehousing old parts (why applecare is a good money maker for them) and like happy campers and I think that battery was recalled no? You may have been entitled to a new one years ago anyway.

You may also have already tried this but checking the logs at /var/log/system.logs (hard to parse) may provide a big picture view of what's going on with the fans even if it's not entirely understandable or easy to get through… sometimes the error messages are verbose and incredibly precise. Hit or miss. It will be FULL of entries that don't matter, but may tell you quite clearly what's going on if you just do a find for like "fan" "heat" "power" "voltage."

Finally (albeit obviously) you may want to make sure you don't have a ton of crud clogging up your fans or blocking. Cleaning a computer directly or with air can easily mess things up… but yeah… this may be necessary. If a sensor cannot get a read on heat or a fan is covered in gunk it may run the fans at full just to get normal cooling in order (first case) or because it's designed to be cautious about the heat issue (second case).

  • Thank you for the many information. Most of them i already tried: pram/vram reset, i full reinstalled, dust cleaned, the battery is already ordered. It may be faulty hardware, since the fan start at boot to max rpm. unfortunatelly i cant find the heat sensor placed anywhere on the logic board. HDD may be a good point, its the original one and is causing slowdowns. I tried many different system diagnostic tools (smcFans, controlFans, iStats) But no fans are found. My idea is that it may be the connection between board and temperature/fans. But that would be the SMC and is part of logicboard(?)
    – TheDomis4
    Commented Sep 13, 2015 at 19:30
  • * that would at least explain why no fans are found and they arent controlled.
    – TheDomis4
    Commented Sep 13, 2015 at 19:36
  • alot of smc errors are thrown pastebin.com/egYkGMrz the first line sounds interesting: ACPI_SMC_CtrlLoop::initCPUCtrlLoop - no sub-config match for MacBookPro4,1 with 8 p-states, using default stepper instead
    – TheDomis4
    Commented Sep 13, 2015 at 20:05
  • Seems like you're booting in safe mode... at least that second boot there. I'm not sure if similar messages prepend the beginning of this log... perhaps it's not reading config files due to a keyed down shift key? Uhm... yeah. Read/write errors make my ears perk up to make sure the hdd isn't unreadable/unwritable due to damage or a permissions errors. I would also confirm if you can get to a boot menu that the right firmware is installed support.apple.com/en-us/HT201518 (it's supposed to bundle with the OS but apparently this can fail to happen as there's a site devoted to it).
    – sas08
    Commented Sep 15, 2015 at 9:50
  • 1
    thank you, the missing battery was the issue. Its working again :)
    – TheDomis4
    Commented Sep 15, 2015 at 16:34

The battery came today, i didnt even noticed that the macbook booted, as there where no noise coming from the fan. Also the keyboard backlight worked straight out of the box. So, my smc-reset either didnt worked without the battery or the ac adapter couldnt find enough voltage. All in all its working like a charm :) thank you!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .