4

I am using an Asus external monitor with 1600 x 900 native resolution connected to my Macbook Air (Yosemite) using a mini display port to VGA adapter. When I try to set the display resolution in System Preferences > Displays, I click "options" and "Scaled" to see a list of additional resolutions ranging from 800 x 600 through 1920 x 1080. For some reason 1600 x 900, the native resolution of the external display is not listed. 1920 x 1080 is the closest match to the native resolution, but it looks awful. How can I set the resolution to 1600 x 900?

  • Try holding option while clicking "scaled" - that should present more resolutions but may not present the resolution you want. I had a similar issue with my MacBook Pro and a VGA monitor. – Harv Sep 15 '15 at 20:38
1

The most likely explanation is that your miniDP to VGA adapter is not an original/high-quality one. I've seen it happen before, and as soon as that person bought an original Apple miniDP to VGA adapter the issue is gone and native resolution is recognized without any issue.

  • That did it! I purchased an adapter from Apple and it's working perfectly with native resolution, didn't even have to mess with the display settings. – JTW Sep 17 '15 at 21:46
0

In System Preferences > Display choose Resolution: Default for display - that should set it to whatever your monitor advertises as it's native screen size. Generally, if you can, try not to use VGA - try to use at least DVI.

  • I have tried that as well and it applies a resolution that is no where near native. The applied resolution makes everything so big that I can only see about 20% of the screen. I hear ya on the VGA thing, but my monitor only has a VGA connector. – JTW Sep 14 '15 at 12:15
  • 1
    Well, maybe try some 3rd party resolution changing app, as in this support case: discussions.apple.com/thread/4599281 – Marek Bettman Sep 14 '15 at 13:02
  • Thanks for the link. If you scan through it you will see that the OPs issue was not resolved using the recommended app. – JTW Sep 14 '15 at 21:45
  • It was not resolved using earlier app, but there is also another one mentioned in the second to last post - don't want to mention the names, since there is no info that any of them worked :) – Marek Bettman Sep 14 '15 at 22:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .