1

I am trying to install monkeysphere on an OS X machine with Homebrew:

$ brew install monkeysphere
monkeysphere: Unsatisfied dependency: Crypt::OpenSSL::Bignum
Homebrew does not provide Perl dependencies; install with:
  cpan -i Crypt::OpenSSL::Bignum
Error: An unsatisfied requirement failed this build.

monkeysphere needs the Crypt::OpenSSL::Bignum perl module and Homebrew is telling me to use the command cpan -i Crypt::OpenSSL::Bignum in order to install that module. After I type:

$ cpan -i Crypt::OpenSSL::Bignum
...
...

And install the dependency, I re-type the brew command:

$ brew install monkeysphere
==> Downloading http://archive.monkeysphere.info/debian/pool/monkeysphere/m/monkeysphere/monkeysphere_0.36.orig.tar.gz
######################################################################## 100.0%
==> Patching
patching file Makefile
Hunk #5 succeeded at 62 (offset 1 line).
Hunk #6 succeeded at 85 (offset 2 lines).
Hunk #7 succeeded at 88 (offset 2 lines).
Hunk #8 succeeded at 92 (offset 2 lines).
==> make install
🍺  /usr/local/Cellar/monkeysphere/0.36: 52 files, 416K, built in 8 seconds
$

Now, monkeysphere is installed, but when I run a command included in the package (e.g. openpgp2ssh), I get the following error:

$ openpgp2ssh < gpg.key 
Can't locate Crypt/OpenSSL/Bignum.pm in @INC (you may need to install the Crypt::OpenSSL::Bignum module) (@INC contains: /Library/Perl/5.18/darwin-thread-multi-2level /Library/Perl/5.18 /Network/Library/Perl/5.18/darwin-thread-multi-2level /Network/Library/Perl/5.18 /Library/Perl/Updates/5.18.2 /System/Library/Perl/5.18/darwin-thread-multi-2level /System/Library/Perl/5.18 /System/Library/Perl/Extras/5.18/darwin-thread-multi-2level /System/Library/Perl/Extras/5.18) at /usr/local/bin/openpgp2ssh line 55.
BEGIN failed--compilation aborted at /usr/local/bin/openpgp2ssh line 55.

monkeysphere is telling me that it still can't find the Crypt::OpenSSL::Bignum perl module I have installed with cpan.

Why doesn't it see the dependency and how can I repair this issue?

Thanks for the attention!

  • Just tried installing monkeysphere (had to install the Bignum module too) and openpgp2ssh works for me. If you run brew doctor does it find any problems with your brew install? – Alistair McMillan Sep 13 '15 at 20:57
  • Thank you for your advice, but I have just found the source of the problem. It appears that the wrong cpan command was issued when I installed Crypt::OpenSSL::Bignum. It was an /opt/local/bin/cpan installed by MacPorts which was bound to a MacPorts' /opt/local//bin/perl Perl which differs from the perl used by openpgp2ssh. I have just installed the module with the correct /usr/bin/cpan using an absolute path on the command line. – user3019105 Sep 14 '15 at 8:12
1

The problem was cpan installed with MacPorts. I had to install the module with $ /usr/bin/cpan -i Crypt::OpenSSL::Bignum, specifying an absolute path for cpan.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .