I found auto-correct incredibly annoying and turned it off soon after installing Lion on July 20th. Auto-correct is fine on a small touchscreen and I can deal with it occasionally correcting to the wrong word, I could not stand it on my real physical keyboard with my Mac.

Since then, I noticed that I am always having to go to the application's Edit menu -> Spelling and Grammar and check the "Check Spelling while Typing" option to get spell check to work and underline misspelled words.

I know that in iOS, if you disable auto-correct, it also disables spell check. Did Apple really think this was a good idea with Lion too, or is it just something only affecting me?


Going to Sys Prefs -> Language & Text -> Text and changing spelling from "automatic" to "U.S. English" and restarting seems to have fixed this issue for me for all but one app.

Notational Velocity seems to still not want to check spelling automatically without me explicitly turning it on from the Edit menu (in that app's preferences, spell checking is set to on). I'm going to assume it's just an incompatibility between Lion and the app. I just installed the nvALT fork and that seems to be working fine.

Glad to see that Lion didn't actually adopt that "feature" from iOS. :)

1 Answer 1


The two settings are independent for me.

What app are you using, where you're continuously forced to turn on spell checking? Most likely it's a bug in that app.

  • It's multiple apps, including Safari, TextMate and Notational Velocity. But other apps like Sparrow, TextEdit and Twitter seem to be remembering the setting in my tests just now. Maybe just some apps having issues with Lion, though like I said, Safari seems to be one.
    – reaganing
    Commented Aug 6, 2011 at 22:44
  • In that case I would submit a bug report to those app developers. It's a bit surprising to see safari on the list though. Commented Aug 12, 2011 at 8:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .