3

This is in the preceding El Capitan Beta (15A278b). I found lots of references with google to hanging app stores but none of the fixes apply to me.

What happens is simple. I click on the App Store and the spinner spins indefinitely. I have tried:

  1. Rebooting
  2. Using the "debug" menu in app store, reset the app, clear cookies
  3. Killing the softwareupdated process
  4. Running softwareupdate -l, which says "no new software available"

All and in different order and combinations.

Any tips? Thanks!

2 Answers 2

1

Tried the ideas above, none worked. Tried them repeatedly.

What did work? Doing a Safe Boot, and updating to El Cap Release Candidate. After that all seems fine again.

0

If softwareupdate --reset-ignored && softwareupdate --list returns an exit status of 0 I would say you have no updates from the server your Mac was chosen to look at. Apple operates a federated cluster of servers and if your subnet has DNS entries, it might even check a local caching server instead of Apple's servers directly.

The hang in the App Store app is probably coincidental and a bug or error in that program. Are you looking to pick apart the MAS using instruments or just be assured that you don't have updates that have been rolled out to your computer?

If it were me, I'd re-download the installer if I couldn't just let the MAS and the Apple servers work out their busy periods this weekend. It could be all on the server end, but I'd need to pick apart the data the servers were sending to be sure.

1
  • 1
    Actually no, I am just simply trying to get into the Mac App store. Nothing happens, I can't buy new apps, or update old apps. It's just dead. In fact what I was trying to do was to update purchased software to get the release candidate of El Cap.
    – pitosalas
    Sep 12, 2015 at 21:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .