5

I am facing a very annoying problem from last few days. Whenever I try to install an app from my Mac to my iPad it says:

This computer is no longer authorised for purchased items

but when I try to authorise this computer, it says:

This computer is already authorised

  • Was this ever solved? – nute Aug 21 '16 at 6:24
  • Actually I had formatted my computer few days back. Now it's working fine. So I don't know what is the actual solution. – Tapas Pal Aug 21 '16 at 17:26
1

You've probably authorised the computer with a different iTunes account from the one that the iPad is using. Have you tried deauthorising it and then authorising it again? (If you've purchased iPad apps on both the iPad and the Mac, using different iTunes accounts, then you've got a problem.)

  • Sorry but this not work for me – Tapas Pal Sep 12 '15 at 10:26
  • In what way does it not work? You can't deauthorise? You can't then reauthorise? You can do both but you still can't transfer apps to your iPad? – Mike Scott Sep 12 '15 at 14:55
  • I can do both, but still can't transfer app to my ipad – Tapas Pal Sep 13 '15 at 8:01
  • OK, can you check that the Apple ID you're using when you reauthorise iTunes is the same as the one shown on the iPad under "iTunes & App Store" in Settings. Then it might be worth signing the iPad out of the iTunes Store and back in again -- tap on the Apple ID to do that. – Mike Scott Sep 13 '15 at 10:05
  • 1
    I checked... both are same. But nothing happen. – Tapas Pal Sep 14 '15 at 7:10
1

I had this same problem. I discovered that at some time in the past I had created another AppleID. My iPhone was "logged" in using one ID, I was trying to sync iTunes using a different ID. Go to Settings> iTunes & App Store and note what your AppleID is. Now in iTunes check to see if you are logged in (upper right near the search box) under a different ID. If you are, log out and try store>authorize using the same ID as your iPhone. I had to de-authorize the computer first because it was registered somehow under the other ID. Then re-authorize using the same ID as my phone. It worked for me.

0

I fixed the issue by signing in the other Apple ID I used to install apps with on my iPad and authorising the computer to keep those apps installed.

After you authorise all Apple IDs used on the device to the computer you should be able to sync your content.

-1

I've fixed the issue by resetting all settings and removing all apps from my iPhone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .