2

I'm a daily user of a couple of IntelliJ IDEs. Unusually for Mac apps (probably because they're Java, not real native apps) they make liberal use of option/alt- keyboards shortcuts. I probably use these unthinkingly hundreds of times a day.

Suddenly they're not working. Either they do nothing, or if the cursor is in a text field, they insert a special character (eg. Ø for option-shift-o).

I don't think this has anything to do with the IntelliJ software per se. I mention them for completeness (and because I didn't use the option-key shortcuts in other apps, so can't be sure of the behaviour elsewhere). This is on a 2013 MB Pro, with both the internal and a bluetooth keyboard.

The one wrinkle in setting up my question is that it's possible this started when I installed the 10.11 RC (I had previously been on release Yosemite). I'm not quite sure, unfortunately, as in the heat of getting work done, I ignored the new shortcut behaviour when it first cropped up (so don't quite remember when that was).

So, has 10.11 introduced something that might have caused this different behaviour? Or is there a setting I might have unwittingly changed? I'd be grateful for any suggestions as to why these shortcuts could have changed behaviour overnight, and what I can do to get the old behaviour back.

  • Can you give a before-and-after example? Eg what did option-shift-o do previously? – Ashley Sep 16 '15 at 8:48
  • I had it bound to trigger a plugin in IntelliJ. But the issue is widespread with Option + <key> shortcuts. Another example: Android Studio has shortcuts for many of the buttons in various dialogs, eg. in the find/replace dialogue, it's Option-R to 'replace all'. Now that just inserts å at the cursor position. The more I think about this, the more I think it must be a change introduced by El Kapitan/10.10 . – Cris Sep 16 '15 at 9:44
  • Try to change keymap and see, if the special characters you are getting are different. If so, than it is a keymap fault. My bet is on some keymap variant that was either changed with new release, or you changed it with some other shortcut. Also: does it happened with both Option keys, or with only one? – Marek Bettman Sep 17 '15 at 20:44
  • 1
    The shortcuts in question mostly aren't part of the IntelliJ platform keymap. They're menu accelerators, which I think are lower level (ie. ui toolkit rather than app-based). – Cris Sep 17 '15 at 22:27
  • 1
    Have you tried the forums for any of those apps? In all standard Mac apps, the option key normally creates special characters. For that not to happen, the app has to bypass OS X default behavior. – Tom Gewecke Sep 21 '15 at 19:33
1

Using option (alt) key is the default way to enter non-latin characters from a keyboard which layout does not have these characters. For instance: I'm Polish, so I need to use Polish characters (like 'ą', 'ę', 'ó' etc.). To do that I use option key (option+a, option+e, option+o).

You can see the variants of keys of your keyboard by enabling keyboard preview: go to System Preferences, choose Keyboard and check the check box in the bottom called 'Show Keyboard & Character Viewers in menu bar' (http://osxdaily.com/2013/06/21/mac-virtual-keyboard-os-x/). Enable it by opening the keyboard menu ('Show keyboard viewer', you can find the instructions under the same link). Now hold the option key - you'll see the variants of keys in your keyboard - you should see the reason to type 'Ø' when you use option+shift+o.

EDIT:

The answer I wrote was the answer to the question in the title: "Why have option- shortcuts in text fields started inserting special characters?".

There a few options:

You may find a solution (the tweaking software I mentioned) to your problem in answer of this question: https://stackoverflow.com/questions/11876485/how-to-disable-typing-special-characters-when-pressing-option-key-in-mac-os-x

  • His question wasn't asking why he was getting the special characters, but rather why his application wasn't intercepting the keystrokes before the OS printed the special character. – miken32 Sep 21 '15 at 21:25
  • @miken32's correct: I wanted to know how to re-enable the previous behaviour (ie. no insertion of non-latin characters with the option key). – Cris Sep 23 '15 at 21:19
  • Does the content from my edit help? – pinus.acer Sep 25 '15 at 20:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .