1

In Safari Preferences, Google is my Default Search Engine; New Windows and New Tabs are set to Homepage.

However, recently whenever I Google something, I click on my choice and I end up on Yahoo Search. Sometimes I get search.epolife.com.

This is very frustrating, I do not want to go to a new search of Yahoo, I like my Google. How can I regain control of Safari?

5

I found my answer in this YouTube video: how to get rid of searchbar redirect in safari.

In Safari's Preferences, select Extensions. There was the epolife. I deleted the epolife extension, quit and relaunched Safari and came back in. After that I no longer have this problem.

  • 4
    Mark it as solved. :) – user14492 Sep 11 '15 at 23:32
2

If you managed to get such an extension installed into Safari accidentally, you are also likely to have other malware on your Mac. Get a good malware removal tool to check your whole Mac (Malwarebytes, for instance).

0

Latest version of Safari had the same problem. When I looked at installed extensions, I found one called "Smart Search" that I had never installed. I uninstalled it, and BINGO...Yahoo gone! possibly a Malware from somewhere.

0

The culprit on my Mac was the extension, AnySearch 1.2.3. I When to Safari > Preferences > Extensions and uninstalled it. Now, I'm back to Google.

0

I was having the same problem. My search bar was set to Google. I couldn’t figure out the problem until:

  • go to your Safari Preferences
  • click “Extensions”
  • if there is an extension named “Search It!” or anything else that you didn’t sign up for in there, delete it!

Hopefully this is helpful

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .