14

Chrome prevents my Macbook from sleeping. See screenshot:

img

Some websites say it might be due to a chrome extension, but I've installed no new extensions in the last two weeks (I've only had this problem for two weeks). Neither did I update OSx, Chrome, or the Energy Saver settings. How do I fix this?

  • 1
    Please can you add the output from the following pmset command to your question. In Terminal.app enter the command: pmset -g assertions – Graham Miln Sep 11 '15 at 10:36
  • Here is a screenshot: Here is a screenshot: postimg.org/image/gcvfqexhh Thanks for your help! – Alex Sep 15 '15 at 6:07
  • 1
    Freakin' great comment @Graham-Miln. Pretty-much should be the answer AFAIK. – HankCa Dec 6 '15 at 10:29
  • And great Question @alex - I didn't realise there was a preventing sleep column. – HankCa Dec 6 '15 at 10:33
4

I had the same issue where Chrome was preventing sleep, i.e., Activity Monitor Energy tab showed that. And I discovered that when I would close a tab running "https://web.whatsapp.com/", that the "Preventing Sleep" column would go to No. When I would open that web site again, it would go back to "Yes".

I found this blog discussing it: http://webdiary.com/2015/01/29/whatsappweb/

That correlates with the output of running pmset -g assertions, which shows:

   pid 229(coreaudiod): [0x00066e6300010845] 01:19:47 PreventUserIdleSystemSleep named: "com.apple.audio.e8-07-bf-12-d6-97:output.context.preventuseridlesleep" 
    Created for PID: 2748. 
2

I woke up to a hot Macbook Pro with just 34% battery after fully charging it, unplugging it, closing it, and putting it in a briefcase the night before. It was so hot it was uncomfortable to hold, and the fan was working overtime. I've followed the same routine hundreds of times before with no similar problem.

Activity Monitor showed Chrome to be the main culprit, and "prevent sleep" was "yes" for Chrome. I had a dozen tabs open, and closed them one at a time to see what changed the status.

In my case, the problematic website was Forbes.com. I was able to toggle the prevent sleep mode by opening and closing a tab with a typical Forbes article. This site has a heavy ad load, auto-play videos, etc. I'm guessing something in their code cycles new videos on the un-refreshed page and is preventing sleep. One time, their video player failed to load for some reason and the prevent sleep indicator never went to "yes." Not definitive, but suggestive. I'm sure other sites with aggressive ad display methods might have the same effect.

  • Yup, same with me except it was goodreads.com – PythonJin Sep 29 '17 at 4:10
  • 1
    I hope this isn't another website mining cryptocurrencies... – Enrico Borba Oct 2 '17 at 5:30
2

This is because, chrome detects if any tab is playing any media file either audio or video (this also includes ads with media). If you have any tab that's playing any media, chrome thinks that you are watching some media and doesn't let your laptop to go sleep mode.

----EDIT---- I was working on a project where i wanted to keep users screen and laptop awake all the time. So i used same trick, i put small hidden html video in code and it did the trick. Audio didnt work though.

1

Try Chrome Canary. It seems to fix this issue.

  • 1
    From the Chrome Canary site: Google Chrome Canary has the newest of the new Chrome features. Be forewarned: it's designed for developers and early adopters, and can sometimes break down completely. It may solve your immediate problem, but introduce others more severe. – IconDaemon Sep 11 '15 at 12:04
  • 1
    Please include a build number, without knowing the specific version, this is not helpful. – joemaller Jun 24 '17 at 15:43
1

I effectively solved the issue by uninstalling the extension D (disconnect.me) Check if you have it installed and disable it.

Go back to the activity monitor and double check if "preventing sleeping" is still set to YES if so: I suspect you could try disabling other extensions with similar results.

1

I had the same problem, MacBook Pro 2014 would not sleep. Quitting Chrome would result in sleep. I disabled the most recent Chrome extension I had added, Tabr | Memory Saver and Chrome Tab Manager, and the MacBook Pro again would sleep. Clearly various Chrome Extensions are capable of preventing sleep.

1

I have discovered that visiting certain websites will trigger this "prevent sleep mode" problem. Right now, I have NO extensions installed, yet when I visit certain websites, the activity monitor shows that the 'no-sleep' mode trigger is set off just by going to the site. Try this: -close individual tabs, one by one, and see if any of them reset the no-sleep trigger off (Activity monitor). Be sure to check for any pop-under tabs. -close all tabs. Check the activity monitor to see if that turns off the no-sleep mode. If not, close and restart Chrome. Recheck the activity monitor. (Your home page may trigger no-sleep.) -After opening any website, see if the no-sleep mode is triggered. This seems to happen especially with the sleazier websites that have pop-under tabs that open, etc. You'll have to close those tabs as well.

1

Check whether you have a tab open with a looping video and close it.

That was my case, I kept putting my Macbook away, and coming back to it with little or no battery left. Turns out I had a tab open with what I thought was an animated gif, but turned out to be a looping video file. Closing that tab fixed everything. Sounds like audio/video files are indeed the culprit.

1

I have found that Google Play Music playing music audio (even in the background) in a tab can "prevent sleep".

When it's playing music in the background, Chrome Preventing Sleep (in Activity Monitor) shows "Yes": enter image description here

Pause Google Play music (I use the media button), and after ~ ten seconds, it changes to "No": enter image description here

Unpause Google Play Music, and almost immediately, it changes to "Yes" again: enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .