2

After working in Windows for a couple of days, then booting back to OSX - I cannot mount my BOOTCAMP partition in Mac OS X any more. Disk utility shows BOOTCAMP as "greyed out". Trying to mount throws an error "The disk BOOTCAMP could not be mounted. Try running First Aid". I cannot run First Aid because it is also greyed out.

I still can boot into Windows just fine via alt/boot. Moreover even Parallels can boot the Bootcamp partition just fine! (I mean, from OSX, as a virtual machine).

PS. I'm using Yosemite, and Windows 10 Bootcamp.

PPS. If I do this:

# cd /Volumes
# mkdir /Volumes/Bootcamp
# sudo mount_ntfs /dev/disk0s4 /Volumes/Bootcamp

It works fine. But it mounts it readonly, also I want it to mount automatically on startup, like it was before...

UPDATE: After digging through the system log I found this: "Windows is hibernated. Will not be able to remount read-write. Run chkdsk." - A-HA! This must be it.

But its not hibernated... Ok, guess I have to boot into windows again and shut-down/restart it a couple of times to clear the hibernation flag...

3
  • Don't try to boot from a Windows partition that is suspended in Parallels. Shut it down first.
    – Tetsujin
    Sep 11, 2015 at 5:06
  • @Tetsujin that is the problem. The partition is NOT suspended/hibernated. I even disabled hibernation with powercfg /h off. Somehow Windows has still marked the partition as hibernated!
    – jitbit
    Sep 11, 2015 at 7:35
  • 1
    Have you tried booting it to Parallels then shutting down, just to see if it would clear the flag? Alternatively try Paragon NTFS or similar to enable Repair & write mount - natively, Disk Utility cannot repair a WIn drive, so that's why it's greyed out. I've never trusted the built-in NTFS write support so idk if that would work
    – Tetsujin
    Sep 11, 2015 at 7:44

2 Answers 2

1

Basically, what worked is booting to Windows natively and shutting it down several times to clear the hibernation flag. Also, disabled hibernation via power-management and via powercfg /h off.

0

Uhh. I was getting this error in the logs:

Mft record size (1024) is smaller than the sector size (4096).  This is not supported.  Sorry.

At least they apologized. I was formatting the bootcamp partition with "format /q c:" in winpe. (I'm imaging it with dism.) It turns out I had to do

format /l /q c:

to get the 4096 mft record size. Then osx won't complain about mounting it. This is on 2017 and newer imacs with the bigger block sizes. The windows setup iso probably does the same thing, but I was doing things differently this time.

You can check the mft size in windows with this as admin:

fsutil fsinfo ntfsinfo c:   

(mft = file record segment)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .