1

I've just tried to install the El Capitan GM, which failed half way through with the error "This Core Storage operation is not allowed on a sparse logical volume group" and gave me the option to restart. Restarting just launches the installer again with the same error.

I then booted into recovery to try and restore from a Time Machine backup. The boot drive was visible, so I tried to restore to it but it failed saying that the volume couldn't be erased. Now the Time Machine restore can't see that volume. Neither can the Internet Recovery option.

The Macintosh HD volume is visible in Disk Utility, verify/repair report no errors. Weirdly, the erase tab isn't visible for that drive, it seems almost like it's locked.

This is a rMBP with an SSD so I'm ruling out a hardware fault for now.


diskutil list shows:

/dev/disk0 with 4 entries:
   0: GUID_partition_scheme - 251GB - disk0
   1: EFI - 209MB - disk0s1
   2: Apple_CoreStorage 250GB - disk0s2
   3: Apple_Boot - 650MB - disk0s3

/dev/disk1 with 3 entries:
   0: Apple_Partition_scheme - 1.3GB - disk1
   1: Apple_partition_map - 30KB - disk1s1
   2: Apple_HFS - 1.3 GB - disk1s2

/dev/disk2 - /dev/disk14 with 500kb untitled entries each.

The others are in the photo below

enter image description here

  • Please add the output of diskutil list, diskutil cs list and gpt -r show /dev/disk0 entered in Terminal while booted to Recovery Mode to your question. – klanomath Sep 10 '15 at 20:06
  • Added the info to my question – NathanGaskin Sep 10 '15 at 20:29
1

Probably the El Capitan installer tried to convert your traditional partition scheme to a CoreStorage volume and failed miserably.

Though a Logical Volume Group and a Physical Volume were built, it still misses a Logical Volume Family and at least one Logical Volume.

You may now either add a Logical Volume or revert to the traditional scheme:

  • Boot to Recovery Mode by holding cmdR
  • Open Terminal in the menubar Utilities->Terminal
  • enter diskutil cs list

To add a Logical Volume enter:

diskutil cs createVolume lvgUUID type name size with lvgUUID: UUID of the Logical Volume Group. It's the first listed.

Example:

diskutil cs createVolume 0E37A07F-7123-4AE4-9C3C-D51D0C05E47E jhfs+ "Macintosh HD" 100g

This will create a 100 GB journaled HFS+ volume with the name "Macintosh HD". To create one Logical Volume using all available space in the Logical Volume Group the following should work instead of 100g: 100% or 250g

Quit Terminal, open Disk Utility and verify the new volume "Macintosh HD". Then use Time Machine to restore the backup.

If the creation of the LV fails some inner structures of the LVG probably are corrupted and you have to delete the LVG.

To delete the Logical Volume Group enter:

diskutil cs delete lvgUUID with lvgUUID: UUID of the Logical Volume Group. It's the first listed.

In your case:

diskutil cs delete 0E37A07F-7123-4AE4-9C3C-D51D0C05E47E

Deleting the Logical Volume Group will automatically create one new classical JHFS+ volume with the name "Untitled" occupying all available space on the disk.

Quit Terminal, open Disk Utility, verify the volume "Untitled" and rename it by erasing it. Then use Time Machine to restore the backup.

  • Trying to create a logical volume gave the same error about the operation not being allowed on a sparse logical volume group. Deleting the logical volume group seems to have done the trick though. It's now restoring from Time Machine. Thank you so much. – NathanGaskin Sep 10 '15 at 21:37
  • @NathanGaskin ;-) Then the inner structures of the LVG were probably corrupted. Until now I have never experienced that. – klanomath Sep 10 '15 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .