4

When I select "Reply All" using Apple Mail my email address automatically gets added back in the original field it appeared in the original message; i.e. if I was CC'd on an email, my address will appear in the CC field when selecting "Reply All".

I've already unchecked the setting in preferences to "Automatically CC myself". How can I prevent receiving a duplicate email in my inbox for every email I send using the "Reply All" option?

7

The default behavior for Mail is that it doesn't cc you when replying unless you've flipped the toggle to cc you on every reply.

But you can get weird mismatches that cause Mail to not identify your own address. This just happened to me with my work Exchange account. I moved to Mail from Outlook and Mail cc'd me on every response.

The resolution for my specific case was that my contact card had my name entered as firstname lastname, while my Exchange account in Mail showed the name as lastname, firstname. When I changed the display name in the Mail account to match how it displayed in my contact card, Mail stopped ccing me.

2

I had the same issue and I managed to solve it by simply editing the Aliases for my account. What I did: in the Mail > Preferences > Accounts > select account, than in the Alias dropdown select Edit Aliases and than I've added a new alias, practically my email address: Full name: myemailaddress@whatever.com Alias: myemailaddress@whatever.com

This solved the issue for me. Hope it help.

  • How does the alias differ from the email address do you say they should be the same? – Mark May 10 '16 at 9:12
  • It is unclear how setting a duplicate alias would resolve this issue. – deiga May 10 '16 at 10:52
  • The answer doesn't appear to suggest adding a duplicate alias, but rather adding an alias (which is named by its address). Could be that this works if the address in question is missing from your contact, for example. – Sam Brightman Aug 3 '16 at 16:00
1

This happens to me only if the address I am replying from is not exactly the same as the address the message came to. For example:

Customer X sends an email to president@company.co and CC's samh@company.co, but that is actually an alias to sh@company.co. When I reply-all, Mail will send a message from: sh@company.co to: Customer X and CC:president@ and samh@company.co.

This makes some sense: How can Mail know that samh@company.co and sh@company.co are the same thing?

  • I agree that would make sense, but I don't have an alias for my address, and the mail comes in as the same address that is applied when clicking "Reply All" – sadmicrowave Sep 10 '15 at 15:44
  • I can't reproduce this on Yosemite 10.10.5. – samh Sep 10 '15 at 15:45
  • How can Mail know that samh@company.co and sh@company.co are the same thing? I would be happy to tell it! – Michael Aug 24 '18 at 18:23
1

Especially with Microsoft Exchange accounts that have a different alias used for login than is actually seen in a recipients 'from' field, one needs to go to Mail -> Preferences -> Accounts, select such exchange account -> Email addresses, and then add both the 'alias@domain.com' and the other human readable email address that usually contains the owners name.surname@domain.com.

This solved the issue for me.

0

I don't think there's a "reply all except for myself" function that's been programmed into Apple Mail. I haven't seen any hidden settings mentioning that, but you could ask Apple Support if you felt there would be such a flag. They would be the only ones with access to the Engineers that would have written that code.

Barring that, you can manually remove yourself or deal with the extra copy. Perhaps opening a second thread asking for software recommendations of mail clients that have implemented the algorithm you propose is worth getting opinions of no one suggests an alternative here.

  • yea, I have Microsoft Outlook 2011 for Mac and it has this functionality built in. I just like built-in OS X apps when I can... – sadmicrowave Sep 10 '15 at 15:00
  • I hope someone can prove my wrongness on this @sadmicrowave and help you out , sometimes a setting is buried where I don't see it. – bmike Sep 10 '15 at 15:02
  • I've done a bunch of searching on my own for hidden/buried settings and forums online but haven't found anything yet :/ – sadmicrowave Sep 10 '15 at 15:02
0

For me this started happening when I switched from gmail to me.com. I put a forward on my gmail account so that my mail is redirected to my @me.com account. In spite of the setting not to do that, Mail will cc:myself whenever replying to messages forwarded by gmail (and thus addressed to my @gmail address), not when replying to messages addressed directly to my @me account.

I offer no solution, but I believe this can be a cause of the problem.

0

For me the problem appeared to be in the Account name (under preferences > Account name). In the default exchange settings, my account name is simply FIRST LAST.

However, in the company directory, the format is FIRST LAST | COMPANY.

By adding the "| COMPANY" bit to the account name, both outlook and Mac Mail then recognised my email address and stopped CCing me into reply alls.

0

This was happening to me on El Capitan, even though I already had my address listed on my contact.

I noticed that Mail automatically adds e-mail addresses that you have sent mail to (maybe via "previous recipients"?) to Contacts. They do not have any information other than the e-mail address.

I had a extra contact card containing only my new e-mail address. It is possible that I first hit reply-all before adding my new e-mail address to my real, original contact card, so I deleted the automatically-added contact card. After restarting Mail the problem was fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .