2

I'm having problem with sending mail via SMTP where the error is username and password does not match, even though they are most certainly correct as the IMAP works. My host wants me to try to uncheck "Automatically detect and maintain account settings" that I access through Mail > Preferences > Accounts, but that checkbox is greyed out and cannot be changed. How can I enable this checkbox?

This is in Yosemite, my email host is Zoho.

Thanks!

enter image description here

2
  • When you first setup your Mail.app with this email account did you do this manually or did you let Mail.app automatically configure these settings for you?
    – denisinla
    Sep 9 '15 at 0:17
  • does your password contain a dollar sign $ ?
    – user146203
    Sep 10 '15 at 18:41
1

My wife and i have been fussing with this all week. Here is her solution. Fixing Mail Problems After Upgrade to Yosemite

  1. Open System Preferences – Internet Accounts a. Highlight the mailbox you want to fix and click the minus button at the bottom of the page

  2. Open Mail Preferences – Accounts a. Click the + sign to add an account b. Enter all the information according to what your ISP requires

  3. After you hit Create to finish entering information and the account shows up in your Mail Preferences list, highlight the new account and: a. Go to the Advanced Tab and uncheck the box that says “Automatically detect and maintain account settings b. Go back to the Account Information tab – Outgoing Server (SMTP) box, click the down arrow and “edit smtp list” c. Delete the old smtp account (from when the account was originally set up) d. Find and highlight the new smtp server that you just entered and go to the Advanced Tab e. Uncheck the “Automatically detect and maintain account settings” and double check to make sure that the settings for your outgoing port, whether or not to use SSL and your authentication method are correct f. Go to the Account Information tab and enter the description you want for this smtp server g. Hit OK

  4. On the Account Information tab for the mailbox you just set up, enter the description you want it to have in your mailbox list. It defaults to the email address, but you can change that if you want.

  5. Also double-check in the Advanced Tab to make sure the incoming port is set correctly.

  6. Click to exit Accounts in Mail Preferences and click Save on the drop down box.

  7. Go back to System Preferences – Internet Accounts and highlight the account you just set up.
    a. If you changed the description of the account in Mail Preferences, change the name of the account to match it. b. If you want to sync Notes as well as Mail, check that box.

0

Admittedly, mine isn't greyed on that point, so I'm not certain whether it will be at both points... but check the other location for that pref, in the other Advanced tab, outside the SMTP setup pane.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .