Recently my automatic timezone update stopped working. (ie it used to work but now it doesn't) Troubling thing is my mac detects the correct location (e.g. Golden, CO), but doesn't use this to update the timezone, despite "Set my timezone automatically..." being checked. See screenshot.

Time & Date preferences showing correct location (Golden, CO), but incorrect timezone (Pacific) Anyone know how to fix this?

This issue now occurs with every network I have tried: work, home, airports, hotels, etc. And, I have already tried the usual set of fixes such as toggling auto timezone off and on, closing system preferences, rebooting, repairing permissions.

OS: OS X 10.9.5 (13F1112)

System: MacBook Pro Retina, 13-in mid-2014

  • Bizarre. How about Maps app geolocation? Is it similarly broken? Are you installing any VPN software or able to test with the Mac tethered to an iOS device with cellular data? – bmike Sep 8 '15 at 16:54
  • I do have a VPN installed (Junos Pulse) for work. But this issue occurs whether or not I am logged in with it. I don't have an easy way to try tethered iOS now, but if I do will comment. – Bryan P Sep 8 '15 at 17:50
  • @bmike: Also, maps app geolocation is spot on. Just like the pin placement in time & date. Problem is not updating the timezone to match. – Bryan P Sep 10 '15 at 3:30
  • I have exactly the same problem: The location pin updates automatically, but the time zone and clock don't. Would love a less drastic solution. – user203018 Sep 24 '16 at 19:22
  • 1
    I am still experiencing this bug in Mojave. – drc Dec 26 '18 at 20:43

This just happened to me on High Sierra. Kept trying to change so that the Mac's location would automatically update the timezone. The Mac could detect where is was (both using the Maps application and the red pin in System Preferences / Date & Time / Time Zone showed the correct location) but the time zone was 'stuck' in the place where I was last week. This continued through reboots and toggling all the options in Date & Time.

Here was the fix for me. In Bash (ie, launch Terminal):

$ cd /etc
$ ls -l localt*

It should be a link to the IANA timezone database like so (assuming this Mac is near LA):

lrwxr-xr-x  1 root  wheel  45 Aug 30 17:32 localtime -> /var/db/timezone/zoneinfo/America/Los_Angeles

If it is not:

  1. Turn off the automatic time zone in System Preferences / Date & Time / Time Zone
  2. In Terminal sudo rm /etc/localtime to remove the incorrect link
  3. Reboot (localtime will be recreated)
  4. Restart automatic time zone in System Preferences / Date & Time / Time Zone

That worked for me after Googling and pulling hair for a few minutes. YMMV.

  • This is the route to go if you're on High Sierra. – zerohedge Nov 17 '18 at 21:08
  • Happened to me after running Migration Assistant to set up my Mac. I had localtime symlinks for two different cities. ➜ /etc ls -l localt* lrwxr-xr-x 1 root wheel 45 Jul 8 23:54 localtime -> /var/db/timezone/zoneinfo/America/Los_Angeles lrwxr-xr-x 1 root wheel 41 Jul 8 23:52 localtime~orig -> /var/db/timezone/zoneinfo/America/Detroit. Solved it by moving the file sudo mv localtime\~orig localtime – johncorser Jul 9 at 15:06

Apparently at least a few others have had this problem. See [ https://discussions.apple.com/thread/7126456 ]. The only solution found to work in that discussion is to:

Solution: Re-install the OS. (Yikes!)

Other attempts in that discussion, including a few beyond those I mention above, didn't work. A new OS install seems rather drastic/painful, so for now I will stick with the

Work around: Switch to manual timezone control.

Hopefully Apple will push a fix soon for Mavericks users, though perhaps all of the focus is on Yosemite and (soon) El Cap.

Any simpler solutions still welcome!


Here is another work around:

  1. Launch the command line terminal (Launchpad-->Terminal)
  2. Run the following command:

    sudo ntpdate -u time.apple.com (It will ask for your password)

That's it! Your clock is now updated with Apple's time server

  • 3
    Nice work around. I don't see this as a true solution since I believe it only updates the time once, rather than setting up automatic updates for time. I edited the text accordingly. +1 – Bryan P Oct 11 '16 at 16:32

After updating to Mojave some location functions were not working despite being enabled i.e. the precise location in setting the time zone and anty location being reported in 'Find My Mac'

The problem was fixed by following advice to reset accessibility in Terminal (taken from here):

tccutil reset Accessibility

Doing so fixed the precise location feature for setting the timezone and enabled the location of my computer to be determined in 'Find My Mac' in iCloud (and in 'Find My iPhone' app in iOS) instantly.


I had the issue for many months since installing Mavericks. Since I run High Sierra and Lion where my geolocation is detected instantly and seamlessly, I have the opportunity to compare various network settings between the two and that has just led to the solution of the issue in Mavericks. The problem stemmed from an incorrect proxy parameter value in the network settings pane of System Preferences. Navigate to the pane then follow this path: Advanced-Proxy, then make notice of a value of the Web-Proxy (HTTP) proxy. It should be, the numeric strings separated with the colon go to the respective boxes (fields). The parameter itself should be unchecked, no authorization credentials required. Exit the advanced preferences, click on "Apply".

Before changing the value of the proxy I ran the network diagnostics. I came up with the latter spontaneously because "Your geo-location is currently unavailable" message showed up in Lion and after the diagnostics it went away.

HTTP proxy settings

  • What kind of service/proxy is listening on port 8228? – nohillside Jul 30 at 7:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .