My iPhone 4 can't download any apps. There's a warning message that says "couldn't download the app at this time" and "done" and "retry". What can I do?

  • 2
    This question lacks basic research on what you've done to solve the issue. It also lacks any sort of specifics. Could you edit it after reading How to Ask? Thank you and Welcome to Ask Different.
    – bmike
    Sep 7, 2015 at 18:59

5 Answers 5


Please try the following steps to fix your problem. After each step, check whether you are still having this problem.

  1. Simply double tap the icon of the app that you are unable to download and wait for a few seconds. Your download should resume.

  2. If you are presented with a button with the option to "try again," note the download progress up to the point where the error occurred, and tap "try again." The error may return, but if the progress has advanced, then keep tapping "try again" over and over until the app is fully downloaded. After doing so, the problem may not return at all for future app updates.

  3. Tap Settings > General > Date and Time > Set Automatically > and slide to turn off “Set Automatically”. Manually set the date one year ahead. Now try to re-download the apps. If you get an error message, go back to turn on “Set Automatically” then try to download the apps again.

  4. Restart your iOS device. Simply press and hold the on/off (sleep/wake) button until you see the red slider and slide the slider to turn your device off. To turn back on, press and hold the on/off button until the Apple logo appears.

  5. Settings > iTunes & App Store > Your Apple ID > Sign Out. Restart your device, then Settings>iTunes & App Store>Sign in and then try again.

  6. Tap Settings > Wi-Fi and turn Wi-Fi off and then on again.

  7. Reset Network Settings by tapping Settings > General > Reset > Reset Network Settings, and then your iDevice will restart. Note that will reset all network settings including your Wi-Fi passwords.

  8. Reset your device by pressing and holding the sleep/wake button and the Home button together until you see the Apple logo.


Try connecting to a VPN and then retry downloading or updating.

I was having trouble updating an app. It would appear to work, then failed with this message:

enter image description here

I had tried many of the suggestions found here, as well as on discussions.apple.com, none of which worked for me. Some suggestions recommended fiddling with wifi, resetting network settings and setting the DNS to I couldn't imagine what most of those suggestions would have to do with the problem. But, I noticed that the common denominator to many suggestions revolved around networking. So, it gave me the idea to try the VPN app on my phone. I tried that and Bingo! Just connecting to the VPN allowed me to complete the update.

To be clear about how I connected to a VPN, I used the PIA app from Apple's App Store. I'm sure there are many VPN options. But, the point is that the connection was made to a VPN server from a VPN client residing on my iPhone. This is an iPhone 5S, by the way.

  • VPN seems to have solved my problem too. Could it be the DNS (Using openDNS).
    – flyboy777
    Jan 22, 2019 at 5:46
  • This worked for me. Was unable to download app updates on my work's wifi network. Tried a hard reboot, forgetting the wifi network, nada.
    – paulmrest
    Feb 12, 2020 at 22:57

Here's one I found on apple.com

  1. Click done when the Done icon show up
  2. Turn on airplane mode
  3. Wait 15 second
  4. Disbaled Airplane mode
  5. Enjoy It And i promise that it will never happen again to your device

Warning: sometimes this does not work

It works better on an iPad device.

  • Repeated hard and soft reboots didn't fix the problem. Turning airplane mode on and back off seems to have fixed it. Also of note, after doing this I got a popup saying there were new iTunes Terms and Conditions I needed to agree to... I suspect this toggling somehow got my phone out of a funk so it could actually prompt me to do that. Sep 17, 2018 at 17:14
  • Worked for me. But need to know why does it happen? And what flight mode actually helps to resolve this?
    – VVB
    Sep 25, 2018 at 9:36

Generally a hard reboot will fix that... To force restart your device, press and hold both the Sleep/Wake and Home button for at least 10 seconds, until you see the Apple logo.


In my case, I just downgraded my iPad 2 to iOS 6.1.3 and was unable to install any app (I can browse in Safari, view App Store etc. however). I tried all solution in the top 2 answers, as well as re-flashed iOS 6.1.3 again, but all to no avail.

Finally, I set up a VPN connection and was delighted that it began to download apps. I also set up an HTTP proxy and it also worked.

IMO, if you have tried Airplane Mode and signing-out then signing-in to your Apple ID and both don't work - go get some VPN or proxy - your network is doing something wacky that you won't solve with your iPhone, iPod touch or iPad. This should particularly be considered if your App Store region doesn't match your location (see below).

It could be that the Communist Party just outright blocked some of App Store's functionality (Note: my Apple ID's region is set to United States, instead of where I live (mainland China)).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .