3

Everytime I open my terminal I get a little notification error:

declare -x Apple_PubSub_Socket_Render="/tmp/launch-jsWpOJ/Render"  
declare -x DISPLAY="/tmp/launch-yARwMh/org.macosforge.xquartz:0"  
declare -x HOME="/Users/Austin"  
declare -x LANG="en_US.UTF-8"  
declare -x LOGNAME="Austin"  
declare -x OLDPWD  
declare -x  
PATH="/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/local/git/bin:/usr/local/MacGPG2/bin"  
declare -x PWD="/"  
declare -x SHELL="/bin/bash"  
declare -x SHLVL="1"  
declare -x SSH_AUTH_SOCK="/tmp/launch-PWYfTW/Listeners"  
declare -x TERM="xterm-256color"  
declare -x TERM_PROGRAM="Apple_Terminal"  
declare -x TERM_PROGRAM_VERSION="326"  
declare -x TERM_SESSION_ID="EA9B2123-82A5-470E-8F9D-328367CEE7BD"  
declare -x TMPDIR="/var/folders/hb/ss6hsppn5497rzzmnx81hh8r0000gn/T/"  
declare -x USER="Austin"  
declare -x __CF_USER_TEXT_ENCODING="0x1F5:0:0"  
declare -x __CHECKFIX1436934="1"  

I don't really know how to get rid of this, I think it might have something to do with XQuartz or X11. Can anyone point me in the right direction to fix this?

  • 1
    Why do you think it has something to do with X11? Are the lines displayed inside your Terminal window, your xterm window or in a separate popup? Is there anything in your .profile or .bashrc which could trigger this? – nohillside Sep 6 '15 at 8:29
  • 1
    The following command might help you identify which config file may be causing the problem. grep -lE 'declare|env' $HOME/.* 2>/dev/null – fd0 Sep 6 '15 at 12:31
  • 1
    This occurs every time I open my Terminal shell. As for the bash command, @fd0, nothing echoed after the search. – austin-millan Sep 6 '15 at 20:23
  • 1
    @SomeGuy -Rename (mv) any of the following files that exits in the root of your home folder: .bash_profile, .bash_login, .bashrc, .profile then drag the com.apple.Terminal.plist in your Preference folder to your Desktop. Logout then log back in. The output that you are seeing looks similar to the command printenv. – fd0 Sep 7 '15 at 12:57
  • 1
    @fd0, It appears .bash_profile is in my /Users folder, and I did a search on my computer for the other ones and I came up empty handed. I also moved my terminal preferences away from my Library (to my desktop) which didn't help with the error either. In fact something weird happened, after I restarted my laptop it didn't request a password (like it's supposed to). – austin-millan Sep 17 '15 at 6:02
3

The reason I was getting the output in my shell for every environment I created was because my ".bash_profile" had a some statements that didn't evaluate to true. The shell was looking for a path that didn't exist anymore, so I had to update the current path so the bash didn't generate an error.

Thanks everyone!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .