1

(Cross-posted in Linux StackExchange)

So I'm trying to dual boot OS X and Manjaro. Using the graphical installer of Manjaro, you're given the option (well, it's an obligation) to create a partition that mounts to /boot/efi.

Manjaro installs without any problem and when the Mac reboots it goes straight up into Manjaro.

The thing is I want to make OS X the default boot option and not Manjaro. If I press alt on the Mac Keyboard just after booting (and before it goes into Manjaro) I get to the disk selection screen and I can select OS X fine, it'll boot correctly.

BUT if I try to make OS X as default boot drive in OS X System Preferences and then go to the alt menu at boot and select the manjaro drive it instead goes to OS X...

I even tried this https://wiki.archlinux.org/index.php/MacBookPro11,x#Method_1:_creating_an_extra_apple-format_bootable_partition_with_GRUB in the Arch Wiki and it gets me to GRUB but then Manjaro fails to boot....

What should I do?

1

My guess would be that OS X is clobbering your GrUB when it sets its own bootloader when you make the change in System Preferences. My advice would be to not set OS X or Monjaro as your default in OS X, but rather use GrUB. You can then set GrUB to default to OS X after a customizable delay, which I assume is the behavior you're looking for. Potentially helpful link

0

It depends on the layout of the partitions.

If you boot the Mac to the chooser screen - hold option when you hear the startup chime - does the Mac OS show?

If so, you can select it and then choose the startup disk.

If not, then the boot chain is compromised. You'll need to boot to internet recovery or boot to another OS to get control of things and re-bless the Mac volume.

You could try resetting the NVRAM - but that wouldn't help in the case where you can't option boot to OS X directly.

  • The question appears to be about Monjaro not booting after setting Mac OS as the default boot volume from within OS X's disk utility, ipso facto OS X loads fine, but then breaks the Linux install – agentroadkill Sep 6 '15 at 2:46
  • @agentroadkill +1 on your post - you might be totally on point what the OP is looking for. Hard to know without more details. Cheers! – bmike Sep 6 '15 at 4:13
  • Agreed. I'm hoping for some feedback as this looks like an interesting issue. Thanks for the bump! – agentroadkill Sep 6 '15 at 11:43
0

Just go to the OS X operating system and search for startup disks in Spotlight. Click on the lock icon and choose the target disk as the MacintoshHD. Now restart in the target disk. That should fix the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .