0

I have a Mac Mini that I use as my home's central media server. However, the actual media files are on my Synology NAS.

To beef up performance and to make the connection to the NAS was kept I recently created a NFS share between my Mac Mini and my NAS. To do so I've set-up an automount to establish the connection.

But since today (a few days after moving to NFS and after the first restart since) I am no longer able to connect to any of my network drives. I have my Synology NAS, a Netgear media player and an Airport Extreme (with my backup drive). I am no longer able to reach any of them, not through SMB, AFP or NFS. All of them state that I don't have enough privileges to access the server. But I am using the same credentials as before and on one of them (the Netgear) I only need guest access.

Any idea what could have broken my network share access?

Edit:

My auto_master:

#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static
/-          auto_nfs

My auto_nfs:

/NFS/media    -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc nfs://diskstation.local/volume1/media
/NFS/files    -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc nfs://diskstation.local/volume1/files

One thing to consider, I initially tried to automount in the Volumes location with the following auto_nfs:

/../Volumes/media    -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc nfs://diskstation.local/volume1/media
/../Volumes/files    -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc nfs://diskstation.local/volume1/files
  • Have you tried if it works with a different machine? – Kevin Grabher Sep 5 '15 at 18:35
  • Other machines (macs) can connect to all drives without any issues. Using the same connection credentials. For some reason all connections through finder fail. – Deddiekoel Sep 5 '15 at 18:38
  • Try a different user on your mac mini, or create a new location in system preferences -> network settings (the dropdown at the top of the window) – Kevin Grabher Sep 5 '15 at 18:40
  • Tried a different user. No luck. – Deddiekoel Sep 5 '15 at 19:01
  • @Deddiekoel Please add the content of your auto_master and your auto_nas (or however you named the file to add the share). – klanomath Sep 5 '15 at 20:07

You must log in to answer this question.

Browse other questions tagged .