2

I've searched around on here and viewed posts such as:

The second one looked most promising, however the solution doesn't seem to give me the empty partition when running diskutil cs list so I can't delete it this way:

diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 2BBFD1F3-XXXX-XXXX-XXXX-XXXXXXXXXXXX
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         447653191680 B (447.7 GB)
    Free Space:   106496 B (106.5 KB)
    |
    +-< Physical Volume F3D5C9AC-XXXX-XXXX-XXXX-XXXXXXXXXXXX
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     447653191680 B (447.7 GB)
    |
    +-> Logical Volume Family FCEE4713-XXXX-XXXX-XXXX-XXXXXXXXXXXX
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         AES-XTS
        Conversion Status:       Complete
        Conversion Direction:    -none-
        Has Encrypted Extents:   Yes
        Fully Secure:            Yes
        Passphrase Required:     Yes
        |
        +-> Logical Volume C6735B8F-XXXX-XXXX-XXXX-XXXXXXXXXXXX
            ---------------------------------------------------
            Disk:                  disk1
            Status:                Online
            Size (Total):          447300763648 B (447.3 GB)
            Conversion Progress:   -none-
            Revertible:            Yes (unlock and decryption required)
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS

This is what Disk Utility gives me:

Disk Utility

As you can see the delete button is unavailable.

I have a Time Machine backup but that only gave me the option to restore to my 447GB disk (the drive is obviously a 500GB).

What are the recommended steps to reclaim my free space? I've tried repairing, and it found some errors in the partition table and supposedly "fixed" them. The situation came about when I created a blank partition and an error was shown. I've since then being trying to delete it with no luck.

2

Solved. I just had to boot into recovery and run

diskutil cs unlockVolume C6735B8F-XXXX-XXXX-XXXX-XXXXXXXXXXXX
diskutil cs resizeStack C6735B8F-XXXX-XXXX-XXXX-XXXXXXXXXXXX 0g

The only strange thing is that Disk Utility shows a blue and white rectangle to represent the drive (unless this is simply showing used space):

Disk Utility

Thanks goes to this post: Resizing or expanding a CoreStorage volume

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .