5

I have recently switched back to Mac after Linux Mint and there is one thing I find very cumbersome:

In fullscreen mode the menu bar at the top goes into auto-hide mode, so it animatedly rolls down when I pull the mouse up to the top. My issue is that, this happens pretty slow. There is a 0.5s delay and then the animation starts to roll the menu bar down. I know it doesn't sound a lot but in practice it gets annoying when I multitask and trying get tasks done fast.

  • Is there a way to remove the delay and trigger the animation instantaneously?
  • Also, is there way to make the animation faster, or perhaps disable it?

Yosemite 10.10.04

  • This is an annoying problem and I agree, we need a way better answer than third party software. Apple needs a fix for this pronto. Either it needs an option to show the menu at all times or an option to delay the menu based on a number of seconds. – Sephethus Feb 26 '16 at 18:05
1

There appears to be no easy way to do this.

In previous versions of OS X, the preference com.apple.springing.delay controlled these timings, but setting this no longer affects the menu timeout on Yosemite (at least not for me).

The keyboard shortcut Ctrl - Fn - F2 pulls down the menubar immediately and focusses it so you can use the keyboard to select menu items (e.g. then press E to select the Edit menu; hit 'Enter' to pull down the menu, then press F to select Find, and Enter to activate). Switching to keyboard shortcuts can improve productivity because your mouse can then stay with the action in the middle of the screen.

Alternatively, commercial software Moom should do what you want.

-1

If you were truly concerned with "trying get tasks done fast", you wouldn't be autohiding the menu bar in the first place! https://en.wikipedia.org/wiki/Fitts%27s_law

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .