1

I'm getting a strange behavior for my Time Capsule (the "tower" model) since I upgraded my home LAN. The problem is that I can no longer browse the content of my Time Capsule using AFP or SMB because the Finder keeps loading. I don't get asked for the password because it's saved in the keychain. I also tried to manually mount Time Capsule using Terminal and mount or mount_afp but nothing changed.

This is the new setup of my home LAN:
enter image description here
All the connections are made using Gigabit Ethernet and Cat5e/Cat6 cables.
Since I connected my MBP and my Windows PC using Ethernet, the Time Capsule is not mounted properly anymore. But if I turn on AirPort and connect to the WiFi network, my Time Capsule works very well.
The only workaround I figured out is that I need to connect the switch directly to the Time Capsule, instead of the Router, to get it working again. So I thought the Router is blocking/not redirecting AFP/SMB traffic to the Time Capsule, in some ways...

I also tried to ping the Time Capsule from the MBP and it pings correctly using TC's IP address and Bonjour .local name. I checked all the possible settings:

  • TC shows up in AirPort Utility and Disk Sharing option is enabled
  • Firewall on my MBP is active but AFP and SMB connections are allowed
  • File Sharing options on my MBP are enabled

And finally, IPs in the entire network are automatically assigned using DHCP reservations, TC is in bridged mode (just a network hard drive) and modem too (internet connection through PPPoE is managed by the router); my MBP runs Yosemite 10.10.5.
Can anyone help me with this weird situation?
Thank you so much!

UPDATE:

  • The modem is my ISP fiber modem (Telecom Italia)
  • The router is a TP-Link Archer D7 modem router which manages almost everything: PPPoE connection, DHCP server, NAT, WiFi 5GHz-only AP, DDNS active, Firewall disabled, Port Forwarding active, IPv6 disabled
  • DHCP range is 192.168.1.101 to 192.168.1.210, subnet is 255.255.255.0, router is 192.168.1.100
  • TP-Link router has 192.168.1.100 IP
  • Computers have 192.168.1.1xx-like IPs: my MBP has 192.168.1.101 IP, 255.255.255.0 subnet and 192.168.1.100 as router
  • Other network devices, like the TC, Smart TV and Printer, have 192.168.1.2xx-like IPs: my TC has 192.168.1.201 IP, 255.255.255.0 subnet and 192.168.1.100 as router
  • The iPhone, which has the same configuration of a computer but 192.168.1.105 IP, can connect to the TC without any problems

Furthermore, using the Console app on the MBP, I figured out that the MBP correctly authenticate with the TC but it is unable to mount it as it keeps requesting reconnect tokens.
Hope this other information can help you and me to solve this problem!

2

I'd go for the obvious - connect the TC to the switch.

You didn't say what IP addresses were being assigned to everything; whether the 2 nodes as you currently have them are on the same subnet; what the router is & how configurable... etc. so the simple fix is remove the router from the equation.

  • Hi Tetsujin, thank you so much for your answer... I've updated the question adding more information about the network configuration. Hope it helps! – matteodv Sep 5 '15 at 9:12
  • After your update, I'd still put the TC on the switch, the router's doing something to upset it, but idk that model so can't really comment. I'd also switch its firewall back on - otherwise every other machine in the building will need to be wary of any incoming connection, even NAT'd or local, as there's no first defence. – Tetsujin Sep 5 '15 at 9:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .