0

I have a Mac mini (Mid 2011) (Macmini5,2) with OS X 10.10.5 and Server.app installed. I would like to share internet from this machine's Ethernet port to my WiFi, so that other devices in my room can connect wirelessly to the wired connection coming into its Ethernet. I have configured Internet Sharing on this machine to use WPA2 Personal.

When I was messing around with Server.app, I also configured one Network (192.168.1.0/24) for the DHCP service in Server.app (for the WiFi device), but the service is disabled.

When I connect a device to the Internet Sharing WiFi network, it takes a while, but eventually the device is assigned an IP along with other DHCP info. But the device cannot reach any IP addresses (pinging local IPs on the network fails and navigating to a website via domain name or IP fails.)

How can I get Internet Sharing to work?

1

Check the IP address assigned to the device via DHCP. Does it match the IP range for the DHCP Network configured in Server.app's (disabled) DHCP service? I.e., is the IP address in the 192.168.1.0/24 range?) Also, try ifconfig -a on the Mac mini and look for a bridge that contains your WiFi device as a member. In the example below (MAC address obscured), I see that my WiFi device (en1) is in bridge100. Does the inet range for the bridge differ from the IP range assigned to your device?

bridge100: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=3<RXCSUM,TXCSUM>
    ether xx:xx:xx:xx:xx:xx
    inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    inet6 fe80::c82a:14ff:fe55:fc64%bridge100 prefixlen 64 scopeid 0xa
    Configuration:
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en1 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 5 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active

If so, try deleting the Network from the DHCP service in Server.app. This fixed the problem for me. After deleting the Network (I think I had to renew the DHCP lease, too), my devices are now assigned IPs in the range of the bridge.

Delete your Networks in Server.app's DHCP service

I think that when Internet Sharing starts, it creates the bridge to support Internet Sharing. So your devices should get IP addresses in its range. I don't know why the Server.app's DHCP Networks interfere with Internet Sharing, since the service is off, but maybe because Internet Sharing forces DHCP on behind the scenes, and the Network settings are picked up regardless. I'm also not sure why an IP in the DHCP service's Network doesn't allow for internet connectivity, but I guess it may have something to do with not matching the bridge's network mask and/or some configuration of pf that Internet Sharing does behind the scenes.

I hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .