0

I imported a not very large (40 GB) iPhoto library into the new Photos app. Photos created a bunch of white images when importing some photos in that library:

Photos.app blank image thumbnails after import

The metadata on these blank photos matches the photo next to it, I can tell that it is supposed to be a duplicate.

  • I ran the repair database option in iPhoto before importing, and it didn't find any photos in the iPhoto folder that weren't in the database. So a bad iPhoto library shouldn't be the issue.

  • I also tried repairing the Photos.app library. While that got rid of many blank photos, it didn't remove all of them.

Searched all over but couldn't find anyone else who had this.

What is a good way to get rid of these? They're harmless but super annoying

1

I have the same problem. It turned out that the photos were gone, recovery had to come from a backup.

You can check if you have the same problem by right-clicking a white photo. Then copy the photo name. Then open a terminal and execute the following commands: cd ~/Pictures; find . -iname <photo name>. If nothing is found, you'll know the photo is gone :(

  • Hm, I don't think that's quite the same problem. The metadata here shows the blanks are duplicate pointers to the same photo. In your case, they were blank because the photos were actually gone. – Kevin Chen Dec 4 '15 at 18:20
0

Turns out these blank photos also fail to upload to iCloud Photo Library. Make a smart album to find them efficiently:

photos app smart album for failed to upload

Then go into the album and delete all the photos (don't forget to hold Cmd!)

  • I am happy it worked for you. I have a similar problem but it does not seem to be the case. The way it happened for me is importing some pictures I generated some years back (some of the fractals I generated in a fractal generator I wrote back then) to the MacBook Pro most of the time (almost always) gets the photos to iPhone. In Photos on the phone it's just a white image. I have seen that before but usually it syncs. In this case not. Thinking I might locate the source files and reimport. Anyway just noting that there seems to be more than one problem. Of course not iPhotos but Photos... – Pryftan Aug 12 at 12:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .