0

I'm very new to the world of Apple so pardon my ignorance & general lack of knowledge.

I only have Terminal access to a Mac which is being used for test purposes. I'm trying to share a folder that I created so I can access it from a Windows machine.

I logged in as "root" and created a folder with the following command:

mkdir /macshare1

I tried sharing with the following command:

sharing -s /macshare1 -S macshare1

Since the IP Address of the Mac is 172.16.26.193, I tried to access this machine from Windows Explorer with the following username:

172.16.26.193\root

But doing so I'm unable to view the share. I'm not sure why it fails to access the folder but can you please help me out if I've missed some command? I'd prefer to give read access to all users.

  • What error messages to you get when it fails to connect? Where did you create the share folder? If you created the folder in /Macintosh HD/macshare1 you may need to go a little deeper and create /Macintosh HD/Shares/macshare1 instead. I remember dimly there was a problem making shared folders at the root level of the HD. – IconDaemon Sep 2 '15 at 20:04
  • Did you also enable File Sharing in System Preferences/Sharing? – nohillside Sep 3 '15 at 5:56
  • So.. Did it work? – tjt263 Sep 4 '15 at 11:27
2

This should be all you need to create an SMB share point:

root@host:~# sharing -a /path/directory  

It will also be available via AFP & FTP by default.


Alternatively, you can specify SMB only instead, like so:

root@host:~# sharing -a /path/directory -s 010

Check for success by listing all share point records:

root@host:~# sharing -l  

It should now be discoverable & accessible to your local network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .