This Macbook Pro (15" circa 2012) is giving me trouble. After a slight water spill incident, I removed and replaced the hard drive, optical drive and battery (warning sticker ignored). After another day drying I turned it on. However, the battery is not recognised, everything's happening slower and the mouse is really jumpy. I've also noticed the CPU load from the Activity Monitor remains steady at 80%-90% for the System (kernel_task). I'd like to reset the SMC to see what happens, but it doesn't seem to be resetting. The PRAM/NVRAM reset is working, just not the SMC reset (I'm using shift-control-option + power). Is there another way to do the SMC reset? Maybe open it up and poke around some more?

  • Does it run on battery at all or only on AC power? It seems like the battery is dead. In that case the Mac will throttle the CPU, which would also be the reason for the high load. – n1000 Sep 2 '15 at 10:24
  • The battery is not recognised. (an X in the battery status bar), and it shuts down if I remove the AC power. I had a theory that the battery was shorted/corrupted during the water incident, but I've got no way to confirm it's just the battery that has the problem. The hardware test revealed nothing. – Shane Sep 2 '15 at 10:25
  • This MBP should have a battery charge indicator at the left. What happens if you press that (without AC connected)? – n1000 Sep 2 '15 at 10:32
  • I guess you followed the official instructions... – n1000 Sep 2 '15 at 10:34
  • I get no response when pressing the side button power indicator. I've also tried refitting the existing battery and the tag connection. – Shane Sep 2 '15 at 10:34

In the Apple Support article on SMC reset it reads "On MagSafe power adapters, the LED might change states or temporarily turn off when you reset the SMC.". Other than that SMC reset does nothing visible. So probably the reset is working.

It seems like the battery is dead. In that case the Mac will throttle the CPU to reduce power consumption. This explains also the high load. Since the battery is necessary to buffers peak loads, the MacBook relies on it to operate properly.

You must replace your battery.

  • I'm just hesitant replacing the battery, when there might be other things going on, and the whole thing is a write-off. I was hoping a SMC reset might reveal more. – Shane Sep 2 '15 at 10:31
  • Tried a new battery. Same issue. – Shane Sep 4 '15 at 3:09
  • @Shane Sorry to hear...That probably means the logic board is damaged :( – n1000 Sep 4 '15 at 4:50
  • @Shane You can run Apple diagnostics by pressing D at startup. But anyway you will have to bring it in. – n1000 Sep 4 '15 at 5:38
  • I've run diagnostics and it says nothing's wrong. On the board I notice some salty calcification between the (i 625 9AHRTZ) and the (f DCO8A FDMS 0349) components. Tried dabbing it with methylated spirits, but that didn't do anything. – Shane Sep 7 '15 at 21:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .