8/5/11 5:21:37 PM kernel FireWire GUID ffffffffffffffff is invalid!

I have a Macbook Pro Core 2 Duo running Snow Leopard. Any suggestions?

  • Do you use an external FireWire drive? – conorgriffin Aug 5 '11 at 22:07
  • I have the same problem and I never plugged anything in the firewire port ever. – djjeck Dec 9 '13 at 5:20

This could happen for a number of reasons, one of those could be that you unplugged a FireWire drive while spotlight was indexing it. You may have to reset spotlight indexes to stop the error appearing if this has happened. You can do so with the Terminal command below.

sudo mdutil -E /

Spotlight will need to reindex all your drives which will take some time, allow it to finish indexing each drive before unplugging it and that may solve the problem

See the link below for an article from someone with a similar issue who solved it performing the steps above



A good test will be to power off the mac and disconnect all FireWire cords.

When you boot, hold Command-Option-P-R to reset the hardware tree which is stored in NVRAM.

If you still get the errors, your OS or FireWire ports are suspect. Since the messages are so numerous, you should be able to narrow down the cause with a little testing.

I'm of the mind that it's more likely a cord or device, but best to start with the mac itself first.


If you don't use the FireWire port, try entirely disabling it. Move out of the /System/Library/Extensions directory all FireWire modules. You can do so by running:

mkdir ~/Desktop/disabled_firewire_modules
sudo mv /System/Library/Extensions/IOFireWire*.kext ~/Desktop/disabled_firewire_modules

in the terminal. Disabled modules will go to the desktop.

Source: https://discussions.apple.com/message/9200953#9200953

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .