I'm using an macbook with Yosemite 10.10.3. There are no problems to access the "standard" internet.

But in my own network I use a local nameserver at my fritz-box. It is configured to use this DNS first before using public DNS. But if I want to access my .local-domain I get an ERR_NAME_NOT_RESOLVED. If I access directly by IP it works.

With a Windows 7 and a Windows 8 computer it works without any additional configuration (access by .local-domain). If I add the DNS to my network-connections it doesn't work again. Seems like my mac doesn't access / resolve .local-domains to this DNS.

Hope anyone has an idea to solve this problem.

PS: for sure - if I edit my /etc/hosts-file for each url it works - but this is not the way I want to go.

EDIT: If I check nslookup myUrl.local I got an Non-authoritative answer with the correct IP address. But I can't send a ping to this url or access it via browser before I added it to /etc/hosts.

  • Are you trying to access the machine as mac.local ? – Mark Sep 1 '15 at 12:33
  • You use a separate DNS server for your .local domain? On Mac OS this is usually done through mDNS, though that shouldn't matter. Check that your Mac has the correct name under System Preferences > Sharing – agentroadkill Sep 1 '15 at 12:35
  • Yes I use a separate DNS. But I don't want to access my / a MacOS by myMacBook.local. There is a local webserver which hosts websites at the (home) LAN like myWebsite.local. Sadly I can't change this url - so I have to tell my MacBook to access myWebsite.local but not as sharing-access by bonjour. – Gersee Sep 1 '15 at 13:07
  • In my experience, OS X doesn't use a DNS priority based on what order you have them listed in Network Preferences. So you cannot dictate that it uses an internal DNS server before an external DNS server. – willWorkForCookies Sep 1 '15 at 13:25
  • @Gersee If I understand everything correctly you may set up a SLD and then it should work better. Instead of using name.tld (e.g mywindows7laptop.local) introduce a SLD like name.sld.tld (e.g. mywindows7laptop.gersee.local). Yosemite meanwhile distinguishes between .local and .sld.local in name resolution. It doesn't work reliable though. Best is to use another tld internally like .private, .home or even .gersee! – klanomath Sep 1 '15 at 14:14

Apple uses .local for bonjour.

This is reserved for mDNS in RFC 6762.

You should not use this in a mixed network. See https://en.wikipedia.org/wiki/.local for further discussion.

up vote 0 down vote accepted

I could solve it (found here):

I run @terminal the following command and now I can open websites like myurl.local:

    sudo discoveryutil mdnsactivedirectory yes

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.