2

I have just installed Kali Linux in a separate partition of an iMac with wireless keyboard and mouse and with rEFInd. When I turn on the Mac it boots into Kali Linux automatically and doesn't recognize the wireless keyboard or mouse. Pressing alt during the boot doesn't show me the menu to select the disk. Please anyone can help me?

The kali Linux system selection appears first so I think that it goes straight to Linux or that the keyboard is not recognized and I cannot change the boot disk.

  • If possible run Kali as a vm, using VMware Fusion you should not experience the issue. – Deesbek Sep 1 '15 at 12:52
0

Press cmd-r when booting to take it into recovery mode. Here you can click on Disk Utility and choose a startup disk/partition. You might need a driver to use the wireless devices with Linux.

  • That doesn't works – Alejandro Sep 1 '15 at 11:38
  • 1
    Does it enter recovery mode at all? – speedstyle Sep 1 '15 at 11:48
  • No it doesn't it goes into kali Linux, I think is because of the keyboard that is not recognized thought Bluetooth – Alejandro Sep 1 '15 at 11:53
  • Do you have another keyboard anywhere? An old windows/mac one will do (preferably USB). I am a little surprised that it doesn't go into recovery, so double-check the keyboard is on (seems stupid but you would be surprised). – speedstyle Sep 1 '15 at 11:55
  • I have done that, I'm looking for a USB keyboard meanwhile I was thinking about using ssh does that would work? – Alejandro Sep 1 '15 at 11:57
0

I resolved the problem so I post it as an answer if someone else have the same problem.

Because the wireless mouse nor keyboard works in kali, I get a wireless mouse and thought a virtual keyboard (you can enable it in accessibility settings in kali) I could enable bluetooth and use my wireless mouse and keyboard. From that I try different things but the solution was deleting the efi file of kali so rEFInd will not detect kali linux and boot into OS X. Finally I delete the partition where kali was. Everything was ok except for some problems with the partitions and I ended formatting the bootcamp one too. Hope that helps anybody. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .