8

Main symptom: When I reboot I get multiple prompts asking for the "local items" keychain password. Details:

  • The password required is my old iCloud password, not my current user account password nor my current iCloud password
  • The keychain access program lists "local items" as a keychain until I log in to one with my old password -- after which it changes to "iCloud"
  • The option to reset the password for both local items (before entering the PW) and iCloud keychain (after) are both greyed out.
  • I cannot stop syncing my iCloud keychain. When I uncheck the box, the box rechecks itself in a second or two.
  • to confuse things, I used my iCloud account as my login for the computer briefly

I have looked at several topics to guide me, but none of them have led to a resolution as it seems the problem is always slightly different.

Any help is highly appreciated!

  • Just commenting to say I have this same problem and haven't found a solution yet either. – orta Dec 3 '15 at 14:32
  • This starts to happens to me after change admin password. I followed some instructions in Apple's support website but didn't work. The password for keychains remains the old one, that's why keep asking for it. – Gustavo Aug 9 '17 at 23:10
3

Sorry to bump an old thread, but I found this simple solution. At least in my experience, the password for the default keychain cannot be changed, so:

1) Create a new keychain (File→New Keychain… ⌥⌘N). I named it temp and gave it a simple password.

2) Right-click the temp keychain and select Make Keychain “temp” Default.

3) Select the original keychain.

4) Edit→Change Password for Keychain [name]… should now be accessible. Select it and change the password to your heart’s content.

5) Right-click the original keychain and select Make Keychain [name] Default.

6) Right-click the temp keychain and select Delete Keychain “temp”

2

Not sure if you ever found the solution, or if Mark's solution worked for you. I recently ran into this issue, and followed the steps at https://scatterbin.blogspot.com/2018/08/change-password-for-keychain-local-items.html and it worked for me.

It seems to be a little known solution, and it took me a while to find this.

From the page:

The following steps should allow you to change the Local Items keychain password, provided that you know your old password.

Restart your Mac. When prompted to enter the password for the "Local Items" keychain, click on Cancel and do not enter your password. Note: you may be prompted multiple time and need to click on Cancel multiple times. Open up Keychain Access (you can look for it via Spotlight). Lock the "login" keychain (yes, the "login" keychain). Unlock the "login" keychain. After unlocking the "login" keychain, you should now be prompted to change the password for the "Local Items" keychain. Change the password to match your user account password.

1

I had the same problem, also tied to using my iCloud account to login.

I was able to resolve the issue by going to System Preferences > iCloud and deselecting 'Keychain' from the list. This reverted the "iCloud" keychain to "local items" in Keychain Access.

The next time the "unlock local items" pop-up appeared, I entered the password and got another pop-up asking me to change my password (enter old, enter new, re-enter new).

I changed the password there to match my login password, logged out and then back in again, and haven't received anymore notifications.

  • 1
    Like the original question, for me if I go to System Preference, iCloud and untick 'Keychain' a second later it ticks itself. – peterjc Aug 4 '17 at 8:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .