2

Recently (possibly since the 10.10.5 upgrade, but not sure) my MacBook Pro mid 2012 (non-retina) changed its sleeping behavior and I cannot seem to restore it. For years, I used a 48 hour hibernate delay (autopoweroffdelay). So when I close the lid or the sleep timer kicks in, my MBP would sleep (i.e. suspend to RAM) and pulse the Sleep Indicator Light (SIL) for 48 hours.

But recently my Mac will wake after approximately 1 hour of sleep and go into another sleep mode. I believe it is standby, because the SIL will turn off, but when I open the lid it takes only slightly longer than after the regular sleep state. In hibernate / autopoweroff it would take a while to load the RAM content back from the disk (which is not the case here). This does not happen when a USB disk is connected.

Here comes my pmset -g:

Active Profiles:
Battery Power       -1
AC Power        -1*
Currently in use:
 standbydelay         172800
 standby              1
 womp                 0
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 gpuswitch            2
 sms                  1
 networkoversleep     0
 disksleep            0
 sleep                10
 autopoweroffdelay    2880
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         10
 acwake               0
 lidwake              1

So my questions are:

  1. Have you heard about any recent sleep-related changes in OS X Yosemite? How come my Mac suddenly ignores its settings?
  2. What standby state am I dealing with? See my guess above.
  3. And of course, how to make my settings work again?

What I tried so far (will update):

  • SMC & NVRAM reset
  • Onyx maintenance
  • Set all timers anew, e.g. sudo pmset -a autopoweroffdelay 2880, etc.
  • Change hibernatemode to 3 as suggested by @rewozz
1

My Macbook Pro 13-inch (2012) also started to show weird signs. When I close the lid and open it after 5 minutes, it wakes up normally. But if I put it to sleep for an hour and wake it, my DVD drive would make a noise like on startup boot. I do not see the overexposed screen with a loading bar like after hibernation. So there is definitely some new kind of power sleep that seem to shut off power to internal devices. I have "Put hard disk to sleep" option unchecked too. And as you mentioned the Power Nap is not supported on this model. Does seem to be a new Yosemite setting.

EDIT - Although, I must admit I noticed that the battery now will last longer once my Mac is asleep for a while. After a few days in a sleep mode, I used to lose some substantial amount of power. Now it is just a few %. So I guess whatever they did, does help to preserve energy.

0

A possible problem could be that you have Power Nap enabled. Power Nap is a service that periodically checks for email, iCloud updates, messages, etc. (in case you didn't know).

In order to check:

  1. Open System Preferences
  2. Open the Energy Saver preference pane
  3. See if the "Enable Power Nap..." checkbox is checked

Note that you may need Admin privileges to change these settings.

Hope this helps!

  • Thanks! However, it seems my Mac does not support this feature. It does not appear in the Energy Preferences. Mine is the non-retina version - will update the question. – n1000 Sep 6 '15 at 21:45
  • 1
    OK! I will see if I can find anything else for you... – Thanks in advantage Sep 6 '15 at 21:46
0

According to Apple:

We do not recommend modifying hibernation settings. Any changes you make are not supported. If you choose to do so anyway, we recommend using one of these three settings. For your sake and mine, please don't use anything other 0, 3, or 25.

Further Apple states:

hibernatemode = 3 (binary 0011) by default on supported portables. The system will store a copy of memory memory to persistent storage (the disk), and will power memory during sleep. The system will wake from memory, unless a power loss forces it to restore from disk image.

You have set:

hibernatemode = 0 (binary 0000) by default on supported desktops. The system will not back memory up to persistent storage. The system must wake from the contents of memory; the system will lose context on power loss. This is, historically, plain old sleep.

Have you tried setting hibernatemode = 3?

Maybe the jig is up, Apple can drop support as they please; hence the warning.

  • Hmm. To be honest I use the App SmartSleep which alters hibernatemode depending on the battery charge :) So it will be 3 once the battery is below 20%. But I will give it a try & report back. Thank you! – n1000 Sep 7 '15 at 15:16
  • FYI SmartSleep was last updated 09 Sep 2013. – eethirteenzz Sep 7 '15 at 15:34
  • I have been using it on 10.8 and 10.10 for 3 years now and it always worked without problems. – n1000 Sep 7 '15 at 17:11
  • Well you know how the saying goes, everything works until it doesn't. – eethirteenzz Sep 7 '15 at 21:21
  • Changing hibernatemode did not help... – n1000 Sep 10 '15 at 20:55
0

As far as I know an apple laptop could wake on its own only because of:

  • PowerNap (see system preferences/PowerSave/Battery/Power Nap)
  • Wake on LAN (see system preferences/PowerSave/AC power/network accesses)
  • or an event received from an external connected device (USB, Bluetooth, ...)

Maybe you could get a clue by looking at your system logs. For example:

  • launch /Applications/Utilities/Console.app
  • and search for "wake reason"

On my MacBook Pro (retina 2015), I only get "wake reason: EC.LidOpen (User)". Maybe there you could find why is your MBP waking up so frequently.

my 2 cents

  • Thanks for the answer. Actually I know why the Mac wakes: Because it changes its standby mode. What I do not know is why. But thank you for the hint with wake reason. The only one I could find was SleepTimer. Will check again tonight. – n1000 Sep 11 '15 at 12:46
0

I can't tell why you Mac wakes up, but here is how you could find out:

Type pmset -b -g assertions in your terminal. That will list the drivers that have requested power setting overrides when running on battery.

You can also inspect the power management log, using pmset -g log.

For example, on my 10.10.5 MacBook Pro 2015, I found out that leaving my Sandisk Ultra fit USB3 memory stick plugged in makes my Mac wake up every 3 hours. Here's why:

$ pmset -b -g assertions
2015-10-19 18:38:32 +0200 
Assertion status system-wide:
   BackgroundTask                 0
   ApplePushServiceTask           0
   UserIsActive                   0
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             0
   ExternalMedia                  1
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0
Listed by owning process:
   pid 51(powerd): [0x000000040008012e] 03:37:52 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" 

ExternalMedia is set to 1 by process powerd.

Unfortunately I haven't found out yet how to prevent this. I looked for a "com.apple.powermanagement.externalmediamounted" plist file but could not find any... So I don't know if these driver overrides can be changed or disabled. :( Anyway, I expect it is driver dependent, so changing the behavior should also be driver dependent...

This detailed web page seems to indicate that, for external media altering sleep behavior, the only option is to unmount or eject the external media. Based on the driver the external media uses, eject is sometime required while for other unmount is enought.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .