0

I have a RAID disk where I keep my virtual machines.

Recently I created and deleted a few and noticed that the space taken up was not being reclaimed.

I tried deleting the .Trashes directory via Terminal but nothing changed.

Has anyone experienced this? I don't want to have to transfer 1.5 TB of data to another disk and back just to fix this.

Update: I tried Verify and Repair disk in Disk Utility which did not fix it. Here is the log FYI.

Verifying volume “RAID”
Verifying file system.
Using live mode.
Checking Journaled HFS Plus volume.
Checking volume bitmap.The volume RAID appears to be OK.File system check exit code is 0.

Verify and Repair volume “RAID”
Repairing file system.
Checking Journaled HFS Plus volume.
Checking extents overflow file.
Checking catalog file.
Checking multi-linked files.
Checking catalog hierarchy.
Checking extended attributes file.
Checking multi-linked directories.
Checking volume bitmap.
Checking volume information.
The volume RAID appears to be OK.
File system check exit code is 0.
Updating boot support partitions for the volume as required.
  • How much space differential are you talking about and how did you determine it? If for the RAID you compare Capacity, Available and Used in both Disk Utility and Finder Get Info, are all values the same or is there a differential? – user3439894 Aug 30 '15 at 17:05
1

I had the same situation two days ago, not on a RAID although I doubt that matters, and I ran Verify Disk in Disk Utility on the drive and it said "Volume bitmap needs minor repair for orphaned blocks" so I then ran Repair Disk and it cleaned it up and my free space was what it should have been after emptying the Trash and it wasn't at the time.

  • Note: I ran Verify Disk and Repair Disk in Disk Utility and was backed up before doing so. As a general rule one should always have everything continually backed up and especially before performing Disk Level Operations of this nature, even thought I've never yet had a disk messed up doing so.
  • This did not work - I updated my post with log. – BAR Aug 30 '15 at 16:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .