0

I am trying to launch a Java program that needs JRE 8. I tried installing it onto my wrapper with the installer, but it showed a message in the style of "Oops, no new executables found, maybe the installer failed?". The solution on my other computer was to download the compact version in tar.gz, put the jar into the jre1.8.0_60\bin directory, cd to it with the Command Line Shell and then run java -jar program.jar. I tried the same on my computer, but this error showed up:

C:\Program Files\jre1.8.0_60\bin> java -jar program.jar

# A fatal error has been detected by the Java Runtime Environment:
#
#  Internal Error (0x80000100), pid=71, tid=49
#
# JRE version: Java(TM) SE Runtime Environment (8.0_60-b27) (build 1.8.0_60-b27)
# Java VM: Java HotSpot(TM) Client VM (25.60-b23 mixed mode windows-x86 )
# Problematic frame:
# C  [KERNEL32.dll+0x1d4d2]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
# An error report file with more information is saved as:
# C:\Program Files\jre1.8.0_60\bin\hs_err_pid71.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

C:\Program Files\jre1.8.0_60\bin>

In the file hs_err_pid71.log, there was the same text as in the Command Line. but with an additional information. I put it on Pastebin because of its length.

  • The error is in the C DLLs that the program calls so we need to know what these are - also being a Java program why run under Wine? – Mark Aug 28 '15 at 14:47
  • @Mark The program is a map editor to a game only available on Windows. If I run the program on a mac, It cannot find the Windows-only game, even if I point to it. – TheBro21 Aug 28 '15 at 14:48

You must log in to answer this question.

Browse other questions tagged .