0

I've installed a Huawei-based "surf stick" (a USB stick with a mobile/wireless modem inside) as a backup internet connection in case my main connection goes down.

I've configured it as a PPP connection in the Network control panel.

All works fine apart from the fact that after a few minutes of idle time on this secondary network interface, the PPP connection gets closed by the system with the message that the connection was idle.

I like to disable this automatic "disconnection when idle".

Apple's support site has this to say about accomplishing it:

Click PPP, and then make sure the “Disconnect if idle for __ minutes” checkbox is not selected, or if it is selected, increase the number of minutes that the computer can remain idle before disconnecting.

Well, this is how it looks on my system:

PPP settings

As you can see, there is no such "Disconnect if idle" checkbox option.

Where is it gone, how do I get it back? Or is there another way to control this setting, maybe with a defaults command?

This is on 10.10.5, BTW.

Also, I wonder why the "Connect automatically when needed" option is disabled. I've asked about this in the Apple discussions forum but didn't get an answer on that, either.

1

I found a solution. The file preferences.plist inside /Library/Preferences/SystemConfiguration contains the configurations for the various network interfaces.

Looking at the file with a plist editor I found the following data under Root / NetworkServices / ... / PPP:

enter image description here

After I've modified the Disconnect... related values from 1 to 0 with BBEdit, the automatic disconnect has been successfully disabled.

However, after another ~40 minutes, the connection was dropped with a different message saying that the connection was dropped because no (phone) number was given. That made no sense to me, because when I manually reconnected afterwards, it worked again. So, there's still something wrong with my setup but the idle disconnection is not it any more.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .