Whenever I have a hard drive plugged in the computer (mid-2011 iMac) that I want to eject, I get the message "unable to eject the volume, an application is using it, would you like to force eject?"

I believe this is new, it didn't do it before when I wasn't under Yosemite.

What is the "application" using the volume? (in most cases)? I am sorry if this is too little information for now to troubleshoot it, I am willing to share more info on my current settings - just tell me how.

1 Answer 1


You can find out what's using the volume with the command:

sudo lsof +D '/Volumes/volumename'

Note that sudo will prompt for your admin password, and it won't echo as you type. The first column will list the name(s) of the processes using files on the volume. In my personal experience, the culprit is usually "mds" and/or "mds_store". These processes are both involved in indexing the files so that Spotlight can search them quickly.

Sometimes they seem to let loose of disk and allow a normal eject, but sometimes not. Unfortunately, I don't know of a real solution; sometimes you just have to use Force Eject.

  • I tried this Terminal command and it enters a process that doesn't print to stdio and doesn't appear to end (after 4 minutes waiting). Aug 28, 2015 at 7:02
  • @wide_eyed_pupil lsof can take a while, but 4 minutes seems a bit extreme. I'd give it quite a while before giving up, though. Aug 28, 2015 at 7:09
  • I gave it an hour, still no good. maybe Time Machine was backing up for some of that but even so… One reason I am interested in this is because when the ext HDD spins down and I do say an open command in InDesign/Pages/whatever there's a delay of 3-8 seconds before the dialogue pops-up as the ext HDD gets the metal up to speed. Not just Open/Save dialogues either. bit annoying. Aug 28, 2015 at 16:21
  • In that case, there's something even weirder going on, and I'm stumped for what it might be. Sorry... Aug 28, 2015 at 16:30
  • Thanks, the only messages I get are when Mac sleeps — it gets errors like "lsof: WARNING: can't lstat(/Volumes/Wizard Earl/Backups.backupdb/MacBook Pro/2014-10-28-213211/Alwick/Library/Application Support/Adobe/PDFL): Operation timed out" Aug 31, 2015 at 9:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .