7

I've had my Macbook Pro for about a year now. It is a late 2013 Retina model running Yosemite. Until a few days ago, its Wi-Fi worked fine. However, after the 10.10.5 update, its Wi-Fi has become very slow and drops packets unless I'm a foot away from my wifi router. When I'm in my usual location of the next room, ping times go up to hundreds of milliseconds.

shanglin$ ping 192.168.1.1  
PING 192.168.1.1 (192.168.1.1): 56 data bytes  
Request timeout for icmp_seq 0  
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=944.501 ms  
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=325.487 ms  
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=78.760 ms  
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=126.286 ms  
Request timeout for icmp_seq 5  
64 bytes from 192.168.1.1: icmp_seq=6 ttl=64 time=41.813 ms  
^C  
--- 192.168.1.1 ping statistics ---  
8 packets transmitted, 5 packets received, 37.5% packet loss  
round-trip min/avg/max/stddev = 41.813/303.369/944.501/335.189 ms 

None of the other devices on my Wi-Fi network are having a problem. I've tried removing plist files from SystemConfiguration, and I've turned off Bluetooth.

My Wi-Fi router is a Cisco E1200 running 802.11n on the 2.4GHz band. I don't think it can run on the 5GHz band. I've tried updating the router's firmware to the latest, but it has not helped.

Any suggestions that could help?

  • 2
    I have the same problem. After the update to Yosemite 10.10.5 the WiFi network does not work properly. With previous versions it was a little slow, but now the WiFi network is almost totally out. It's not a problem in the router, it's a problem with the software running in the mac itself. The problem goes even worst if you turn on the Bluetooth to use a mouse or a keyboard (this happens to me). If you delete all WiFi connections and then map your router again, for a few minutes is gonna work fine, but then the problem appears again. I just wonder why I spent almost 3000€ in a macBook Pro lapto – user143238 Aug 27 '15 at 7:23
  • Tonight my wifi seems to be working significantly better, but I haven't changed anything. Strange! – slec Aug 29 '15 at 6:13
  • I have the same problem. I felt very lucky when everybody had a problem but me. But since the update to 10.10.5 my wifi drives me crazy. It's very unstable and until now I couldn't find a way to get it fixed. My hope lies on El Capitan. I'm almost willing to install the Beta. This is very annoying. – user145382 Sep 4 '15 at 14:07
  • I have the same problem with my 5 year old Macbook Pro. Upgraded to 10.10.5. No problems, then the wifi went slow. Tried several fixes, they worked, then wifi trashed again. I'm ready to go back to Windows. – user145553 Sep 6 '15 at 2:20
  • 1
    Same problem here... is it already confirmed by Apple? Any thoughts on fixing this? – bo-oz Sep 15 '15 at 13:36
1

Jeez, those ping results are terrible.

I'm on El Capitan now, but I can relate to your frustrations about the wifi. My macbook pro is a late 2012 model. I travel with my laptop and rely on it as my phone. It was a real show stopper when wifi would completely bork on the road as in not letting me connect to open SSIDs.

I made this extreme script to wipe out wifi settings and it worked for me, but it is a pain to re-enter ssid/passwords etc and for some reason the problem would show up every now and then.

For me, if wi-fi doesn't work what's the point of having a keychain? I just wanted it to work, so I was willing to wipe things out to make it so. Mac OSX will create new clandestine defaults, but obviously if you want your passwords to friend's wifi etc, backup your keychain.

You can try the script but be warned, it may not fix your problem, it may even make things worse. I do not accept responsibility for use of this script. Please look at the files and directories it is deleting.

Alternately copy and paste everything but the "#!/bin/sh" bit and run it in a terminal, I have it in script form because it was a recurring issue for me on Yosemite, the problem went away when I either upgraded or clean installed Mavericks (can't remember which I did), so I would consider upgrading your OS to Mavericks possibly. El Capitan is still painful right now with bugs and so on, but at least wifi works.

#!/bin/sh
cd /Library/Preferences/SystemConfiguration
rm com.apple.accounts.exists.plist 
rm com.apple.airport.preferences.plist
rm com.apple.captive.probe.plist
rm com.apple.network.eapolclient.configuration.plist
rm com.apple.smb.server.plist
rm NetworkInterfaces.plist
rm preferences.plist

You must log in to answer this question.

protected by Community Sep 6 '15 at 4:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .