I deleted my local iTunes Library since I assumed I could listen to the music anyway using Apple Music. After deleting my music files by emptying home/music/iTunes/iTunes Media/Music I have three types of tracks, based on the column iCloud download:

  • Files with this icon cloud with downward pointing arrow: I can play them without problem.
  • Files with this icon cloud with diagonal slash: These won't play, which is expected, I have already accepted that these tracks will have to be added manually.
  • Files without an icon: If I try to play those I this popup The song "could not be used because the original file could not be found. Would you like to locate it" and the exclamation mark is added in front of the title of the track. If I choose Locate I get a Finder window and the option to point Apple Music towards the local file, which is expected. However, and here is the rub, if I choose Cancel the song plays, the exclamation mark disappears and this cloud with downward pointing arrow icon appears after the title of the song. Which is unexpected but nice.

I'd have to execute the steps under 'Files without an icon' about 6000 times to be able to play most of my tracks again.

1 Answer 1


After a lot of trial and error and messing about with Apple script the solution turned out to be deceptively simple: Select all songs in your library and in the context menu and choose the option remove download.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .