1

I have a MacBook Pro running 10.10.5 and a Thunderbolt Display. I access the internet using "Display Thunderbolt", my ethernet cable is plugged into the display and the display Thunderbolt cable is plugged into the MacBook Pro. Everything works fine.

However, I need to use my MacBook Pro on the ethernet network without going through the display. I have a brand-new Apple "Thunderbolt to Gigabit Ethernet Adaptor", but when I plug it into my MacBook Pro's thunderbolt port, the MacBook proclaims that "None of the member interfaces is connected."

What troubleshooting steps can I take to diagnose the problem and get my MacBook Pro on the ethernet network?

ETA: On the advice of emotality below, I have tried the following without success.

  1. Plugging the ethernet cable into the Thunderbolt Ethernet Adaptor which I then plugged into the Thunderbolt port on the display.
  2. Adding, by hand, a new Thunderbolt Bridge service.
  3. Plugging the Thunderbolt Ethernet Adaptor into both ports on the MacBook Pro

I have also tried setting the "Configure IPv6:" drop down to Link-local only".

Also, to clarify, I need to do this as I need to use my MacBook Pro in another location which has an ethernet connection but no wifi and I can't take my monitor there. (And because it should work, should it not?)

  • Did you try plugging it in the Thunderbolt port in your display? Did you add a new network for this adaptor in your Network Preferences? – emotality Aug 25 '15 at 22:03
  • I have tried plugging the ethernet cable into the Thunderbolt Ethernet Adaptor which I then plugged into the Thunderbolt port on the display. A box popped up saying a new network interface was detected, but the Status show "Not Connected". – pheon Aug 25 '15 at 22:24
  • Un-plugging from the display and plugging into the MacBook Pro, no box pops up. If I add a new "Thunderbolt Bridge" service, it shows Status: Not Connected. – pheon Aug 25 '15 at 22:27
  • Have you tested the cable with the display's ethernet port? And may I ask why you dont connect wifi and ethernet, instead of two ethernets? :P – emotality Aug 25 '15 at 22:28
  • What happens if you swop the two cables? :S – emotality Aug 25 '15 at 22:29
2

This question may be a duplicate. Try some of the suggestions here: How to force Thunderbolt-ethernet connection when switching networks without restarting computer?

It sounds to me like an issue with connecting to your router.

Try the suggestion to renew your DHCP lease under System Preferences > Network Preferences > Advanced for the Thunderbolt Ethernet. Or if you have a static IP address, make sure the right IP address, Subnet Mask, and the correct DNS server are entered.

Is there a reason you are trying to go through the Thunderbolt Bridge setting and not Thunderbolt Ethernet?

Also click on the Apple icon in the Menu Bar and look at your Locations. If something other than Automatic is selected, those Location preferences could be stopping your MBP from connecting to the Router. You will also see this at the top of the Network Preferences for your connection.

UPDATE

Is there a reason you are trying to go through the Thunderbolt Bridge setting and not Thunderbolt Ethernet?

I asked you this above. When I looked at my MBP connected with a Thunderbolt Ethernet Adapter, I checked under Thunderbolt Bridge and saw the exact message you have.

The thing is that I am Connected via Thunderbolt Ethernet and all of my configurations for my connection to the router are there.

enter image description here

  • 1
    Thanks. I realize now that my old Adapter was broken, and I couldn't ever see a "Thunderbolt Ethernet" service and assumed that "Thunderbolt Bridge" was what I wanted. My bad. Thanks for clearing up my confusion. – pheon Aug 26 '15 at 13:19
  • I had to flip my thunderbolt adapter to have the bolt face upward before "Thunderbolt Ethernet" came up in my Network Settings panel. – knownasilya Sep 6 '18 at 18:32
-1

Make sure the cable that you plugged in is not "mini display port cable". Thunderbolt cable 2 is with "thunder icon" on cable ends.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .