0

I have been using a 1 TB SSD with my 17" MacBook Pro Early 2011. With the recent availability of 2 TB SSD's, I wanted to upgrade to the larger size. I have upgraded my HD several times since I purchased this MacBook four years ago, including two years ago when I installed the 1 TB SSD (as well as having upgraded a previous Early 2009 model).

Each time, I used SuperDuper! to transfer the partition to the new HD (connected via USB), and then put the new HD into the MacBook Pro. I then turned on FileVault, and the new HD partition was encrypted.

However, this time was different -- when I tried to turn on FileVault, I got the message that I can't enable FileVault because the recovery partition is missing. Using diskutil list, but not Disk Utility, I can see a recovery partition on the old HD. Of course, I believe my MacBook came with the operating system (which I think was Lion) on DVD's, before the operating system was being shipped on the recovery partition. I had previously upgraded the old 1 TB SSD to Yosemite.

There are a few mentions of this problem online, including Can't Enable Filevault because Recovery Partition Missing from 2011, suggesting reinstalling Lion. http://www.techrepublic.com/article/pro-tip-restore-the-recovery-partition-in-os-x-10-10-yosemite/ suggested reinstalling the operating system, but also suggested that that might result in system instability in the future, and therefore suggested using Carbon Copy Cloner 4. https://www.linkedin.com/pulse/how-re-create-missing-recovery-partition-os-x-mattia provides instructions about creating a new recovery partition, but doesn't specifically mention the problem with FileVault, or whether following that process would allow FileVault to start.

1

I seem to have solved the problem, and FileVault is processing my new SSD as I write this. Because I did not find a complete solution online, I wanted to put my notes here.

I followed the instructions at https://www.linkedin.com/pulse/how-re-create-missing-recovery-partition-os-x-mattia, basically downloading the Yosemite installer from the App Store, making a separate copy from the Applications folder in case I needed it, and then running the installation. That post suggested that the installation would take about 30 minutes, but my installation took significantly longer. The first pass took only about 16 seconds, and then the system rebooted, and the Yosemite installation itself began. The initial message was that it would take 44 minutes, and the first 43 minutes ran normally, but when the progress bar was at about a minute remaining, it stopped moving, and it literally took several hours for that last minute to complete, but ultimately it did, and the system rebooted.

Once that had completed, running diskutil list in a terminal window does show Apple_Boot Recovery HD. I was able to configure FileVault, and I have my 2 TB SSD. The operating system version is 10.10.5, which appears to be the current version, having been released on about August 13.

Finally, I would mention that I did slightly reduce the size of the 2 TB partition to 1.98 TB before running the Yosemite install, so that there would be space for the recovery partition. However, I don't know that that was necessary, and I probably wouldn't do it next time, especially since I don't seem to be able to change the size again now that I am using FileVault. Next time, I would make sure that the Recovery Partition was present (using diskutil list from a Terminal window), and then maximize the main partition size.

Also, when I initially created the Mac partition on the new SSD using Disk Utility, I did not create it as an encrypted, but rather used "Mac OS Extended (Journaled)" I think that was correct, but would be interested if anyone knows a better way.

  • Welcome to Ask Different. Thanks for the knowledge dump. +1 – bmike Aug 24 '15 at 2:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .