5

I have the following problem: I used the optical bay to use a HDD in my mid 2010 13" Macbook Pro in addition to my SSD. It was working just fine until a few days ago, when it started to get "slower". VLC Player (on SSD) wasn't able to play videos on the HDD anymore, and when I tried to copy files from the HDD to the SSD it took ages (the speed was about 20 mb/m). Also it took a really long time to see what's in a folder when I opened it (but after 5-10 seconds I could at least see what files were in which folder).

My first question is: Is my HDD slowly dying? What could the problem be?

A friend was trying to help me repair it (he tried several things in the terminal and in safe mode - I do not remember all of it, but anyhow.. nothing worked). During this we unmounted the HDD and since then I am not able to mount it anymore. When I try

diskutil mount /dev/disk1s2 

in the terminal it says

Volume on disk1s2 failed to mount If the volume is damaged, try the "readOnly" option

How can I try to mount it in readOnly mode?

diskutil mount readOnly /dev/disk1s2

doesn't work..

I would really appreciate it if you could help me. I have a lot of new photos and music on the HDD I have not backed up yet.

  • Additional info: I removed the HDD from the Macbook and put it into an external case. And the HDD seems to be ok from the outside. At least it doesn't make any unusual sounds like other dying HDDs. – r-newbie Aug 23 '15 at 21:43
  • did you find a solution? – Braian Mellor Oct 12 '16 at 20:50
4

Enter in Terminal.app:

sudo asr adjust --target /dev/disk1s2 --settype "Apple_HFS"

and then try:

diskutil mount readOnly /dev/disk1s2
  • 1
    hey look at this: $ sudo asr adjust --target /dev/disk4s1 --settype "Apple_HFS" Trace/BPT trap: 5 $ diskutil mount readOnly /dev/disk4s1 Volume on disk4s1 failed to mount If the volume is damaged, try the "readOnly" option – Braian Mellor Oct 12 '16 at 20:52
  • 1
    this still didn't work for me: I got the same error – demiculus Jan 16 '17 at 6:53
-1

TO your first question, yes probably your disk is dying :(

To your second question, try mounting with either diskutil mountDisk /dev/disk1s2 or diskutil mountDisk readOnly /dev/disk1s2

This is required if there are multiple partitions in the disk, read man page of diskUtil, that would help.

  • 1
    How does mounting a volume as a disk (if this even works) solve the issue described in the question? – nohillside Mar 8 at 9:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .