2

This question already has an answer here:

I am currently surrounded by a long list of WiFi connections and every time I boot up my MacBook Pro, it switches away from what should be the default for the public WiFi connection.

How can I force my Mac OSX to recognize the domestic connection it should be using?

Is there also any way to block the listing of other WiFi connections, especially because there are so many?

I have tried going through the Network listings to delete the surrounding superfluous signals and have not been able to. Is there something I'm missing? Do they specifically have to be connections I've joined? Is it not possible to block out the other domestic signals around me?

marked as duplicate by bmike Aug 23 '15 at 14:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

Go to System Preferences -> Network.

On the left sidebar click Wi-Fi and then "Advanced" at the right bottom corner.

Now choose the tab Wi-Fi and you'll see a list of all the wireless network you joined. Drag networks in the order you prefer (e.g. the domestic network should be the first).

Update: on the same screen, if you want to remove some of the networks your computer has joined simply select the network name and then click on the - (minus) button to remove it (Note: your computer will not join automatically that network again). If you want to stop listing networks, on the same screen, uncheck the option "Remember networks this computer has joined"

Not the answer you're looking for? Browse other questions tagged .