0

I'm having a problem with Yosemite. It started when I attempted to move items to recycle bin, and was asked for my password. I entered it, and the items were moved to the bin. When I tried secure empty trash, it worked for a minute then froze. So I halted the trash. I then tried to move the folders back to the desktop to see if I could get the trash down to only a few files that weren't in folders (these files hadn't asked for my password to move to recycle). That didn't work, because when I restored the folders to desktop, the computer copied them instead of just restoring them: one copy of each folder remained in the trash, another copy now on desktop. When I moved those folders back to trash from desktop, they were then in duplicate. Now I have over 150 GB in the trash and it won't empty. Help!

  • p.s. These files were copied over from another (dead) computer using a borrowed external drive. I no longer have access to either the computer or the external drive. – Not a techie Aug 21 '15 at 19:04
  • What is your question? Do you want to empty the Trash and delete the files, or do you want to restore a copy of the files? – aaplmath Aug 21 '15 at 22:14
  • thank you for your replies! my goal is to empty the trash and make certain the files are securely deleted. yes, i have tried the force delete to empty trash by holding down the command key. unfortunately, it didn't work. regarding the sudo command, what is the risk of using it? also, is there a way to specify secure empty trash with that command? i'm concerned because i also tried to "free empty space" using disk utility, and was unable to complete that task. the computer gave an error message that it was unable to create a temporary file. i'd like to be certain the files are permanently and s – user142610 Aug 22 '15 at 20:24
1

Have you tried secure-delete? When you go to empty trash hold down the command key. This has helped me empty the trash when it was stubborn for whatever reason.

0

See this answer: Can't empty the trash after deleting user account

sudo rm -rf ~/.Trash/

As you no longer have access to the drive that the files were sent to Trash from, you may have to force empty the Trash. Be careful, this is a delicate operation. Anytime you see sudo beware that you are treading in dangerous ground.

DESCRIPTION
sudo allows a permitted user to execute a command as the superuser or another user, as specified by the sudoers file.

DESCRIPTION
The rm utility attempts to remove the non-directory type files specified on the command line.

0

Same issue. Solved by changing Finder preferences from empty secure trash to just empty trash. Everything worked beautifully in seconds. Just sayin'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .