1

I just upgraded to a new Mac and a newer OS X release than I previously was running and have encountered some different behaviour in Safari 8 that I can't turn off around offering to save passwords.

In Safari 7 you could disable auto-fill for passwords which would stop Safari ever prompting you per How to completely disable password saving in Safari which is what I had done in the past.

However with Safari 8 the preferences pane looks slightly different and frustratingly enough the relevant option is greyed out and there is no obvious way to disable it:

Greyed Out Option

Any idea how I can disable this behaviour under Safari 8?

  • Sorry to be no help but n my Safari 8 all are selectable - What OS version are you in and are you using an admin account - and on the Safari Passwords tab is Autofill selected there? – Mark Aug 21 '15 at 17:48
  • 1
    Yosemite (10.10.5), using an Admin account, Passwords tab also has auto-fill selected but greyed out – RobV Aug 21 '15 at 17:54
-1

Your Mac or settings are broken for Safari to be locked like that.

This is likely an issue with your user account settings since all the Macs I have allow you to uncheck those marks. First, try going to the Passwords tab and turning off all check marks there before returning to the AutoFill tab.

Before wiping your user settings and preferences, can you verify that making a new user on the mac and logging in to that account, you are seeing the same issue?

If it's a system issue the steps to fix it are radically different than if it's a user level issue.

See Isolating issues in Mac OS X and Mac OS X: How to troubleshoot a software issue

-2

For FireFox, go to Preferences, click on Security, uncheck "Remember logins for sites". And, if you want, click on the Saved Logins button and delete all the saved passwords.

I assume something similar is available in all browsers that offer to save passwords.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .